RecoverPoint: 在 GUI 或 CLI 中修改 NTP 設定時,伺服器 [java.lang.NullPointerException ] 中捕獲到例外狀況
Summary: 在程式碼升級至 4.1.2.x 或 4.3 後,用戶端無法立即修改 NTP 伺服器。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
RP 從先前版本
升級至 4.1.2.x 或 4.3:RecoverPoint 分割器:VNX 分割器
EMC 軟體:EMC RecoverPoint 4.1.2.x
EMC 軟體:EMC RecoverPoint (RP4VM) 4.3
對用戶端的影響:如果沒有預先定義的主要或次要 DNS,我們無法變更 NTP 伺服器 IP,因為 null 指標例外 (NPE)。
對 RP 的影響:嘗試修改設定時,會從installation_server引發 NPE。
在記錄中找到的症狀:
伺服器中捕獲到的異常 [java.lang.NullPointerException]。
在installation_server日誌中,有 (路徑檔: files/home/kos/installationLogs/server.log)
2016-01-11 20:25:59,687 [CommandWorker-6] (Command.java:69) ERROR - Command#run() 可拋出。故障 UID:9dda9d2a-9037-405a-bb7f-e01f009baebd java.lang.NullPointerException at com.kashya.installation.server.commands.global.modify.modifications.DnsModifier.isSiteChanged(DnsModifier.java:10)
升級至 4.1.2.x 或 4.3:RecoverPoint 分割器:VNX 分割器
EMC 軟體:EMC RecoverPoint 4.1.2.x
EMC 軟體:EMC RecoverPoint (RP4VM) 4.3
對用戶端的影響:如果沒有預先定義的主要或次要 DNS,我們無法變更 NTP 伺服器 IP,因為 null 指標例外 (NPE)。
對 RP 的影響:嘗試修改設定時,會從installation_server引發 NPE。
在記錄中找到的症狀:
伺服器中捕獲到的異常 [java.lang.NullPointerException]。
在installation_server日誌中,有 (路徑檔: files/home/kos/installationLogs/server.log)
2016-01-11 20:25:59,687 [CommandWorker-6] (Command.java:69) ERROR - Command#run() 可拋出。故障 UID:9dda9d2a-9037-405a-bb7f-e01f009baebd java.lang.NullPointerException at com.kashya.installation.server.commands.global.modify.modifications.DnsModifier.isSiteChanged(DnsModifier.java:10)
Cause
作為修改的一部分,installation_server檢查globalsystemconfig.xml中的每個部分以查看它是否已更改。檢查 DNS 時,會擲出 NPE,因為沒有設定 DNS。不應發生這種情況,因為 DNS 不是強制性的。
Resolution
因應措施:
這個問題有解決方案,但是必須由 EMC 技術支援人員介入。支援人員必須存取您的儲存裝置系統才能修正此問題。如需技術協助,請聯絡 EMC 客戶支援中心或您的服務代表,並引用此 EMC 知識庫解決方案 ID。
解決方案:
此問題已在下列 RecoverPoint 版本中解決:4.1.SP3、4.3.SP1 和 4.4.P1
若要判斷是否適合您的環境,請聯絡 EMC 客戶支援中心或您的服務代表,並參考此解決方案 ID。
這個問題有解決方案,但是必須由 EMC 技術支援人員介入。支援人員必須存取您的儲存裝置系統才能修正此問題。如需技術協助,請聯絡 EMC 客戶支援中心或您的服務代表,並引用此 EMC 知識庫解決方案 ID。
解決方案:
此問題已在下列 RecoverPoint 版本中解決:4.1.SP3、4.3.SP1 和 4.4.P1
若要判斷是否適合您的環境,請聯絡 EMC 客戶支援中心或您的服務代表,並參考此解決方案 ID。
Affected Products
RecoverPointProducts
RecoverPointArticle Properties
Article Number: 000065291
Article Type: Solution
Last Modified: 04 Aug 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.