NetWorker: Backups fail with: 'Client is not properly configured on the NetWorker Server'

Summary: A NetWorker client-based backup fails with the error 'client CLIENT_NAME; is not properly configured on the NetWorker Server'.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Backups fail with the following errors:
Error: 'client (Client_name); is not properly configured on the NetWorker Server'
Error: 'Cannot start session with server (ServerName): client `(Client Name)' is not properly configured on the NetWorker Server'

Cause

Most likely causes:

  • Incorrect TCP/IP configuration on client.
  • Mismatch of client name and Aliases on client resource configuration.
  • Client's entire alias name is not updated under aliases list of the client machine.

Resolution

Check 1:

Use nslookup CLIEN_NAME from the NetWorker server. Replace CLIENT_NAME with the name of the NetWorker client as it is configured in NetWorker. The client configuration can be reviewed from the NetWorker Management Console (NMC) or NetWorker Web User Interface (NWUI) under Protection->Clients.

Check the hosts file on the NetWorker server and the client to ensure that no conflicting names are entered for the NetWorker server or client.

Linux: /etc/hosts
Windows: C:\Windows\System32\drivers\etc\hosts

NetWorker: Name Resolution Troubleshooting Best Practices

If any Domain Name System (DNS) issues or hosts file conflicts are observed on either system. Correct them accordingly. 


Check 2:

Confirm the NetWorker server can connect to the NetWorker client and see the client ports:

nsrrpcinfo -p CLIENT_NAME

root@lnx-nwserv:~# nsrrpcinfo -p win-client01.prod.lan
PROGRAM VERSION PROTOCOL PORT SERVICE
100000  2       tcp      7938 nsrportmapper  Port Mapper
100000  2       udp      7938 nsrportmapper  Port Mapper
390436  1       tcp      9896 nsrexecd       GSS Authentication
390435  1       tcp      7989 nsrexecd       Resource Mirror
390440  1       tcp      8305 nsrexecd_nsrfa Remote File Access
390113  1       tcp      7937 nsrexecd       Remote Execution

From the NetWorker client, confirm that you can connect to the NetWorker server.

nsradmin -p nsrexecd -s NSR_SERVERNAME

Where NSR_SERVERNAME is the NetWorker server name as it appears in the NetWorker Management Console (NMC) or NetWorker Web User Interface (NWUI).

If the NetWorker client has the extended client package, you can also use nsrrpcinfo from the client back to the server. If the extended client software is not installed, you cannot use nsrrpcinfo on a client.

Linux: rpm -qa | grep lgtoxtdclnt
Windows: Check Programs and Features check to see if NetWorker Extended Client is listed, or use command:

wmic product where "Name = 'NetWorker Extended Client'" get name, IdentifyingNumber, PackageName

nsrrpcinfo -p NSRE_SERVERNAME


The Default NetWorker service port range is 7937-9936.

NetWorker Processes and Ports

NOTE: If The client or server cannot communicate with each other over the NetWorker service ports, check the operating system firewalls for any rules blocking this communication. If there is no operating system firewall blocking this communication, check with the network administrator for any network firewalls which may be blocking these ports.

 

Check 3:
The client may be configured in NetWorker with one name but responding with another. 

1. Confirm the client's name as it is seen on the NetWorker Server from the NetWorker Management Console (NMC) or NetWorker Web User Interface (NWUI) under Protection->Clients.

2. On the NetWorker server run:

nsradmin -p nsrexecd -s CLIENT_NAME

3. From the nsradmin prompt enter:

show name

4. Enter: 

print type: nsrla

Example:

root@lnx-nwserv:~# nsradmin -p nsrexecd -s win-client01.prod.lan
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> show name
nsradmin> print type: nsrla
                        name: win-client01.amer.lan;
nsradmin> quit
The client is configured in NetWorker with one name, but the client's nsrexecd process is responding with a different name.

5. Update the client's aliases field to include the name seen in the clients nsrla entry:

NetWorker client aliases

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000072315
Article Type: Solution
Last Modified: 22 Oct 2025
Version:  5
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