Windows Server: Det går inte att konvertera Server Core-utvärderingsversionen till standardversionen utan utvärdering

Summary: Server Core-versionen (utan det grafiska gränssnittet) av Windows Server 2019 eller 2022 Standard kan inte konverteras från en utvärderingsversion till en icke-utvärderingsversion. Det finns ingen känd korrigering för det här problemet förutom att installera om utvärderingen med det grafiska gränssnittet Desktop Experience. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Om utvärderingen av Windows Server 2019 Standard eller 2022 Standard, som kan laddas ned från MicrosoftDen här hyperlänken tar dig till en webbplats utanför Dell Technologies., installeras i Server Core-läge (d.v.s. utan det grafiska gränssnittet för skrivbordsupplevelse) kan den inte konverteras till den "fullständiga" (icke-utvärderade) Standard-versionen.

Den procedur som stöds för att utföra den här konverteringen är densamma som för att uppgradera en Standard Edition-installation till Datacenter-utgåvan:

  1. Kör "dism /online /get-targeteditions" för att visa en lista över de tillgängliga utgåvor som det operativsystem som körs kan konverteras till.
  2. Kör "dism /online /set-edition:<target> /productkey:<key> /accepteula" för att påbörja konverteringen, där <target> är namnet på den önskade målutgåvan som anges i utdata från steg #1, och <key> är en giltig produktnyckel för den utgåvan av Windows Server.

 

Den här proceduren dokumenteras på flera platser, inklusive Microsofts webbplats. Men när det första kommandot körs på en Server Core-installation av 2019 eller 2022 Standard utvärderingsversion visas utdatalistorna ServerDatacenterCor som den enda möjliga målutgåvan:
Skärmbild som visar ServerDatacenterCor som den enda tillgängliga målversionen
Figur 1: ServerDatacenterCor visas som den enda tillgängliga målversionen.

ServerStandardCor bör också anges som en målutgåva, men den saknas. Om konverteringen görs med ServerStandardCor som mål visas följande fel:
Skärmbild som visar fel 1168 när ServerStandardCor anges som målversion
Figur 2: Fel 1168 ges när ServerStandardCor anges som målversion.

 

Obs! Produktnyckeln som visas ovan är den allmänna volymlicensnyckeln, eller KMS-klientnyckeln, för Windows Server 2019 Standard, som kan hämtas härifrånDen här hyperlänken tar dig till en webbplats utanför Dell Technologies.. Den kan inte användas för att aktivera Windows Server 2019 utanför en KMS-miljö.


Informationen dism.log Filen som nämns i skärmdumpen ovan indikerar att konverteringen är tillåten och börjar köras. Det misslyckas dock snart med följande fel:

DISM Transmog Provider: PID=### TID=### Failed to copy edition license file. - ThreadSkuInstallEula(hr:0x80070490)
Error code 0x80070490 translates to "Element not found."

Cause

Det här är ett känt fel.

Resolution

Detta verkar vara ett problem i Windows Server 2019 och 2022 Standard-utvärderingsavbildningen när den installeras i Server Core-läge. Det finns ingen känd lösning på det här problemet förutom att installera om utvärderingsoperativsystemet med skrivbordsupplevelsen inkluderad. Tester har visat att denna version kan konverteras till den icke-utvärderade versionen med hjälp av dism.exe kommandon som nämns ovan.

Metoden "dism /online /cleanup-image /restorehealth" åtgärdar inte det här problemet, eftersom det inte är ett resultat av att komponentlagret är skadat.

Om du konverterar från Windows Server 2019 eller 2022 Standard Server Core-utvärderingen till ServerDatacenterCor upplagan lyckas . Detta kräver dock en giltig produktnyckel för Windows Server 2019 eller 2022 Datacenter Edition.
 

Affected Products

Microsoft Windows Server 2019, Microsoft Windows Server 2022

Products

C Series, Modular Infrastructure, Rack Servers, Tower Servers
Article Properties
Article Number: 000136346
Article Type: Solution
Last Modified: 14 Aug 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.