VPLEX: dispositivo distribuido que experimenta problemas de rendimiento
Summary: Un dispositivo distribuido VPLEX está experimentando problemas de rendimiento debido a la alta latencia de escritura.
Symptoms
Los hosts experimentan una alta latencia de escritura en los dispositivos distribuidos de VPLEX.
Cause
En el caso de los dispositivos distribuidos, VPLEX confirma que cualquier I/O de escritura se confirme en el almacenamiento de back-end en ambos sitios antes de devolver el reconocimiento al host.
Si la red WAN FC/IP entre clústeres experimenta congestión, aumenta el tiempo de ida y vuelta de los paquetes de I/O. Este aumento provoca el problema de rendimiento.
Por otro lado, VPLEX siempre gestiona I/O de lectura desde la caché global, si los datos están disponibles, o desde el arreglo de back-end local.
Las prácticas recomendadas de VPLEX indican que el RTT entre los clústeres de VPLEX no debe superar los 5 ms para obtener un rendimiento óptimo. Para una red de todo el campus, el RTT no debe superar 1 ms.
Resolution
-
Revise los registros de firmware para ver los eventos com/21 y com/24 que indican congestión de red.
Ejemplo:
128.221.253.36/cpu0/log:5988:W/"00601661de2210138-2":141384:<4>2017/04/12 09:16:16.10: com/21 COM IO took 1.047 sec to complete (limit 900.000 msec). Type message, uuid 0x4xxxxxx, transport scsi, msg_len 72 128.221.252.38/cpu0/log:5988:W/"0060165322f014450-2":2170302:<3>2016/10/22 23:29:35.92: com/24 86 long-latency IOs in past hour (Msg: 86) Printed up to 100.
-
Confirme que todos los puertos WAN COM estén activos y que la alimentación del SFP sea superior a 200 uW. Si no es así, siga el artículo de la base de conocimientos: VPLEX: 0x8a45901c, el puerto IP detecta que no hay alimentación o no recibe 0x8a453013, enlace de red IP inactivo (es posible que sea necesario iniciar sesión en el soporte de Dell)
-
Si VPLEX tiene una configuración metro FC y los switches WAN FC son compatibles con Dell, siga el artículo de la base de conocimientos: Switches Connectrix: cómo recopilar registros de switches (principales) (es posible que sea necesario iniciar sesión en el soporte de Dell). Recolecte los registros del switch y comuníquese con el soporte de Dell.
-
Si VPlex es la configuración metro IP, valide el estado de la red IP para determinar qué está causando la congestión.