VPLEX : périphérique distribué rencontrant des problèmes de performances
Summary: Un périphérique distribué VPLEX rencontre des problèmes de performances en raison d’une latence d’écriture élevée.
Symptoms
Les hôtes sont confrontés à une latence d’écriture élevée sur les périphériques distribués VPLEX.
Cause
Pour les périphériques distribués, VPLEX vérifie que toutes les E/S d’écriture sont validées sur le stockage back-end sur les deux sites avant de renvoyer l’accusé de réception à l’hôte.
Si le réseau WAN FC/IP intercluster est congestionné, le temps d’aller-retour des paquets d’E/S augmente. Cette augmentation provoque le problème de performances.
D’autre part, VPLEX sert toujours les E/S de lecture à partir du cache global si les données sont disponibles, ou à partir de la baie back-end locale.
Les pratiques d’excellence VPLEX indiquent que le RTT entre les clusters VPLEX ne doit pas dépasser 5 ms pour des performances optimales. Pour un réseau à l’échelle du campus, le RTT ne doit pas dépasser 1 ms.
Resolution
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Vérifiez dans les journaux du firmware les événements com/21 et com/24 qui indiquent un encombrement du réseau.
Exemple :
128.221.253.36/cpu0/log:5988:W/"00601661de2210138-2":141384:<4>2017/04/12 09:16:16.10: com/21 COM IO took 1.047 sec to complete (limit 900.000 msec). Type message, uuid 0x4xxxxxx, transport scsi, msg_len 72 128.221.252.38/cpu0/log:5988:W/"0060165322f014450-2":2170302:<3>2016/10/22 23:29:35.92: com/24 86 long-latency IOs in past hour (Msg: 86) Printed up to 100.
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Vérifiez que tous les ports com WAN sont actifs et que l’alimentation du SFP est supérieure à 200 uW. Si ce n’est pas le cas, suivez l’article de la base de connaissances : VPLEX : 0x8a45901c, le port IP ne détecte aucune alimentation de réception ou 0x8a453013, liaison réseau IP interrompue (une connexion au support Dell peut être nécessaire)
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Si le VPLEX est une configuration FC Metro et que les commutateurs FC WAN sont pris en charge par Dell, suivez l’article de la base de connaissances : Commutateurs Connectrix : comment collecter les journaux du commutateur (principal) (une connexion au support Dell peut être requise). Collectez les journaux du commutateur et contactez le support Dell.
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Si le VPlex est une configuration IP Metro, vérifiez l’intégrité du réseau IP pour déterminer la cause de l’encombrement.