VPLEX: dispositivo distribuito che presenta problemi di prestazioni
Summary: Un dispositivo distribuito VPLEX presenta problemi di prestazioni a causa dell'elevata latenza di scrittura.
Symptoms
Gli host riscontrano un'elevata latenza di scrittura sui dispositivi distribuiti VPLEX.
Cause
Per i dispositivi distribuiti, VPLEX conferma che qualsiasi I/O di scrittura viene sottoposto a commit nello storage back-end su entrambi i siti prima di restituire la conferma all host.
Se la rete WAN FC/IP tra cluster presenta congestione, il tempo di round trip dei pacchetti di I/O aumenta. Questo aumento causa il problema di prestazioni.
D'altra parte, VPLEX serve sempre I/O di lettura dalla memoria cache globale, se i dati sono disponibili, o dall'array back-end locale.
Le best practice di VPLEX indicano che l RTT tra i cluster VPLEX non deve superare i 5 ms per prestazioni ottimali. Per una rete a livello di campus, l RTT non deve superare 1 ms.
Resolution
-
Controllare i registri del firmware per verificare la presenza di eventi com/21 e com/24 che indicano la congestione della rete.
Esempio:
128.221.253.36/cpu0/log:5988:W/"00601661de2210138-2":141384:<4>2017/04/12 09:16:16.10: com/21 COM IO took 1.047 sec to complete (limit 900.000 msec). Type message, uuid 0x4xxxxxx, transport scsi, msg_len 72 128.221.252.38/cpu0/log:5988:W/"0060165322f014450-2":2170302:<3>2016/10/22 23:29:35.92: com/24 86 long-latency IOs in past hour (Msg: 86) Printed up to 100.
-
Verificare che tutte le porte COM WAN siano attive e che l'alimentazione SFP sia superiore a 200 uW. In caso contrario, consultare l'articolo della Knowledge Base: VPLEX: 0x8a45901c, la porta IP rileva assenza di alimentazione di ricezione o 0x8a453013, collegamento di rete IP inattivo (potrebbe essere richiesto l'accesso al supporto Dell)
-
Se VPLEX è una configurazione FC metro e gli switch WAN FC sono supportati da Dell, consultare l'articolo della Knowledge Base: Switch Connectrix: come raccogliere i registri degli switch (primario) (potrebbe essere richiesto l'accesso al supporto Dell). Raccogliere i registri dello switch e contattare il supporto Dell.
-
Se VPlex è una configurazione IP metro, convalidare lo stato della rete IP per determinare la causa della congestione.