AppSync: Der Serviceplan schlägt beim Erstellen eines SnapVX-Snapshots einer großen Anzahl von SQL-Datenbanken mit VSS-Timeout fehl
Summary: AppSync stößt beim Erstellen eines Snapshots von mehr als 50 Datenbanken, für die ein SQL-Serviceplan abonniert ist, auf mehrere VSS-Timeouts, obwohl kein Performanceproblem im SMI-S-Server vorliegt. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Der AppSync-SQL-Serviceplan kann keinen SnapVX-Snapshot von mehr als 50 Datenbanken erstellen, da mehrere VSS-Timeouts auftreten, obwohl der SMI-S-Job in einer Sekunde abgeschlossen wird.
Beim AppSync VSS-Service ist eine Ausnahme aufgetreten: Die VSS-Replikation ist während des Wiederaufnehmens fehlgeschlagen. Weitere Informationen finden Sie im Host-Plug-in-Protokoll und im Anwendungsereignisprotokoll.
Beim AppSync VSS-Service ist eine Ausnahme aufgetreten: Kopie konnte nach 3 Versuchen nicht erstellt werden. Weitere Informationen finden Sie im Host-Plug-in-Protokoll und im Anwendungsereignisprotokoll.
Beim AppSync VSS-Service ist eine Ausnahme aufgetreten: Kopie konnte nach 3 Versuchen nicht erstellt werden. Weitere Informationen finden Sie im Host-Plug-in-Protokoll und im Anwendungsereignisprotokoll.
Cause
AppSync führt die folgenden Aufgaben während des 10-Sekunden-Zeitfensters "Freeze-Thaw" aus:
Für den folgenden Serviceplan sind 55 Datenbanken abonniert.
AppSync-Serverprotokolle:
Wenn ein Serviceplan für mehr als 50 SQL-Datenbanken abonniert und als Teil eines einphasigen Pits geschützt sind, können alle diese Schritte zusammen mehr als 10 Sekunden dauern.
Infolgedessen wird das Zeitüberschreitungsfenster von 10 Sekunden überschritten und der Serviceplan schlägt fehl.
- Ruft das gesamte Dateisystem der Anwendung und die zugeordnete RDF-Geräteentität aus der Persistenz ab.
- Prüft den RDF-Gerätestatus für SRDF/A und SRDF/S.
- Erstellung eines SnapVX-Snapshots im Array
Für den folgenden Serviceplan sind 55 Datenbanken abonniert.
AppSync-Serverprotokolle:
|
31.05.2018 12:25:57.513 DEBUG [EJB-Standard - 6][com.emc.archway.entitycommands.phasepit.entity.GetPhasePitCopiesCommandBean] [<AppSync-Servername>] [] fc68ba37-5fa5-4e35-8b46-39f613dfaa67->>>Es wurden 55 Diagrammelemente des Typs Klasse com.emc.archway.datamodel.ArchwayApplicationCopyStatusEntity gefunden 31.05.2018 12:26:02.185 DEBUG [EJB-Standard - 6][com.emc.archway.entitycommands.phasepit.entity.GetPhasePitCopiesCommandBean] [<AppSync-Servername>] [] fc68ba37-5fa5-4e35-8b46-39f613dfaa67- Die Zeit, die benötigt wird, um alle Kopien von phasepit 7b5d1c20-a765-4e4b-9db3-6fc38191ccdb zu erhalten, beträgt 4750 ms.>>> |
||
.
.
|
Infolgedessen wird das Zeitüberschreitungsfenster von 10 Sekunden überschritten und der Serviceplan schlägt fehl.
Resolution
Führen Sie ein Upgrade auf AppSync Version 3.8 durch, um die Korrektur für dieses Problem zu erhalten.
Durch die Korrektur werden die Schritte 1 und 2 (Auflisten des Quellgeräts und Überprüfung des SRDF-Status) außerhalb des VSS-Freeze-Fensters verschoben.
AppSync kann von der Produktsupportseite unten heruntergeladen werden.
https://support.emc.com/products/25364_AppSync
Durch die Korrektur werden die Schritte 1 und 2 (Auflisten des Quellgeräts und Überprüfung des SRDF-Status) außerhalb des VSS-Freeze-Fensters verschoben.
AppSync kann von der Produktsupportseite unten heruntergeladen werden.
https://support.emc.com/products/25364_AppSync
Article Properties
Article Number: 000167904
Article Type: Solution
Last Modified: 18 Sept 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.