AppSync: El plan de servicio falla con tiempo de espera agotado de VSS mientras se toma una instantánea de SnapVX de una gran cantidad de bases de datos de SQL
Summary: AppSync detecta varios tiempos de espera agotados de VSS al tomar una instantánea de más de 50 bases de datos suscritas a un plan de servicio de SQL, a pesar de que no haya ningún problema de rendimiento en el servidor SMI-S. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
El plan de servicio de SQL de AppSync no puede crear una instantánea de SnapVX de más de 50 bases de datos, ya que encuentra varios tiempos de espera agotados de VSS, a pesar de que el trabajo de SMI-S se completa en un segundo.
El servicio de VSS de AppSync detectó una excepción: La replicación de VSS falló durante la reanudación. Consulte el registro del plug-in del host y el registro de eventos de la aplicación para obtener más información.
El servicio de VSS de AppSync detectó una excepción: No se pudo crear una copia después de 3 reintentos. Consulte el registro del plug-in del host y el registro de eventos de la aplicación para obtener más información.
El servicio de VSS de AppSync detectó una excepción: No se pudo crear una copia después de 3 reintentos. Consulte el registro del plug-in del host y el registro de eventos de la aplicación para obtener más información.
Cause
AppSync realiza las siguientes tareas durante la ventana de congelamiento y descongelamiento de 10 segundos:
El siguiente plan de servicio tiene 55 bases de datos suscritas.
Registros del servidor de AppSync:
Si hay más de 50 bases de datos SQL suscritas a un plan de servicio y protegidas como parte de un PIT monofásico, todos estos pasos juntos pueden tardar más de 10 segundos.
Como resultado, se vulnera la ventana de tiempo de espera de 10 segundos y falla el plan de servicio.
- Obtiene todo el sistema de archivos de la aplicación y la entidad de dispositivo RDF asociada a partir de la persistencia.
- Verifica el estado del dispositivo RDF para SRDF/A y SRDF/S.
- Crea una instantánea de SnapVX en el arreglo.
El siguiente plan de servicio tiene 55 bases de datos suscritas.
Registros del servidor de AppSync:
|
05-31-2018 12:25:57.513 DEBUG [EJB default - 6][com.emc.archway.entitycommands.phasepit.entity.GetPhasePitCopiesCommandBean] [<AppSync Server Name>] [] fc68ba37-5fa5-4e35-8b46-39f613dfaa67->>>Se encontraron 55 elementos de gráfico de tipo class com.emc.archway.datamodel.ArchwayApplicationCopyStatusEntity 05-31-2018 12:26:02.185 DEBUG [EJB default - 6][com.emc.archway.entitycommands.phasepit.entity.GetPhasePitCopiesCommandBean] [<AppSync Server Name>] [] fc68ba37-5fa5-4e35-8b46-39f613dfaa67->>> El tiempo necesario para obtener todas las copias de phasepit 7b5d1c20-a765-4e4b-9db3-6fc38191ccdb es de 4750 ms |
||
.
.
|
Como resultado, se vulnera la ventana de tiempo de espera de 10 segundos y falla el plan de servicio.
Resolution
Actualice a AppSync versión 3.8 para obtener la corrección de este problema.
La corrección mueve los pasos 1 y 2 (lista de dispositivos de origen y comprobación del estado de SRDF) fuera de la ventana de congelamiento de VSS.
AppSync se puede descargar desde la página de soporte del producto que aparece a continuación.
https://support.emc.com/products/25364_AppSync
La corrección mueve los pasos 1 y 2 (lista de dispositivos de origen y comprobación del estado de SRDF) fuera de la ventana de congelamiento de VSS.
AppSync se puede descargar desde la página de soporte del producto que aparece a continuación.
https://support.emc.com/products/25364_AppSync
Article Properties
Article Number: 000167904
Article Type: Solution
Last Modified: 18 Sept 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.