Avamar: Jak aktualizovat referenční informace k metadatům zálohy: záloha byla ručně stažena z vrstvy Cloud Tier datové domény

Summary: Software Avamar udržuje a používá metadata zálohování k provádění potřebných obnovení cloudové vrstvy pro mřížku Avamar integrovanou se systémem Data Domain. Tento článek vysvětluje, jak znovu synchronizovat ručně odvolané zálohy DD a aktualizovat metadata Avamar. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Správný postup odvolání zálohy z cloudové vrstvy Data Domain (DD) do aktivní vrstvy používá nástroj Avamar "avtier", jak je zdokumentováno v serveru Avamar: Jak odvolat zálohy, které byly migrovány do vrstvy Data Domain Cloud Tier.

Tento článek se zabývá scénáři, kdy nebyl použit správný postup a odvolání bylo ručně provedeno v systému DD beze změn v softwaru Avamar.

Po ručním odvolání systému DD je záloha v aktivní vrstvě DD, ale metadata Avamar pro zálohu ji zobrazují v cloudové vrstvě.

Například:

avmgr getb --path=/clients/ClientName --format=xml --incpartials | grep -i 1D359BBB62CE6BA
backuplistrec flags="24117249" labelnum="592" label="***_Exchange_Full-1510201386783#0" created="1510274087" roothash="fff989cfe0fe0654abc5453466fcbe7b12879207" 
totalbytes="3537383718912.00" ispresentbytes="0.00" pidnum="3018" percentnew="0" expires="0" created_prectime="0x1d359bbb62ce6ba" partial="0" retentiontype=
"daily,weekly,monthly" backuptype="Full" ddrindex="1" locked="0" direct_restore="1" tier="2" appconsistent="not_available" sealstate="COMPLETE"/>

(Výstup je zabalen kvůli čitelnosti)

Z tohoto výstupu tier="2" označuje, že systém Avamar stále rozpozná zálohu jako uloženou v cloudové vrstvě.

Pokusy o obnovení této zálohy z nástroje Avamar způsobí při vyvolání odvolání nový (zbytečný) přesun dat v systému DD mezi aktivní a cloudovou vrstvou.

Cause

Pokud systém Avamar neprovedl zálohu staženou z cloudové vrstvy Data Domain do aktivní vrstvy, metadata pro tuto zálohu v systému Avamar nebudou synchronizována s umístěním dat v systému Data Domain.

Resolution

Tento problém je možné vyřešit dvěma způsoby:

1. způsob: Synchronizace metadat zálohy mezi GSAN a Data Domain spuštěním uvolňování paměti (GC) s "checkalltierduringgc" povoleno:

Varování: Nemohou být spuštěny žádné další úkoly údržby.
 
Poznámka: Ruční uvolňování paměti může běžet až 60 minut.
 

1. Zastavte plánovač údržby: 

dpnctl stop maint 
 

2. Povolte changealltiering parametr:

avmaint --ava config checkalltierduringgc=true
 

3. Spusťte uvolňování paměti:

 avmaint --ava garbagecollect 
 

4. Monitorujte mřížku, dokud se GC nedokončí, pomocí jednoho z níže uvedených příkazů:

avmaint gcstatus -- or -- status.dpn
 

5. Po dokončení uvolňování paměti zakažte changealltiering parametr:

avmaint --ava config checkalltierduringgc=false
 

6. Restartujte plánovač údržby:

dpnctl start maint
 

2. způsob: Ručně aktualizujte metadata zálohy pomocí "avmgr chgt":

Poznámka: Tím se problém okamžitě vyřeší a záloha se zpřístupní pro obnovení.
 

1. Vytvořte kontrolní bod Avamar pro případ, že se vyskytnou nějaké problémy.

2. Pomocí následujícího příkazu se dotázejte na stav zálohy, která má být stažena z vrstvy Cloud Tier Data Domain. Zaznamenejte parametr "created_prectime" hodnotu.

avmgr getb --path=/clients/ClientName --format=xml --incpartials |grep 'labelnum="<labelnum>"' 
 

Například:  

avmgr getb --path=/clients/ClientName --format=xml --incpartials |grep 'labelnum="592"'
backuplistrec flags="24117249" labelnum="592" label="***_Exchange_Full-1510201386783#0" created="1510274087" roothash="fff989cfe0fe0654abc5453466fcbe7b12879207" totalbytes="3537383718912.00" ispresentbytes="0.00" pidnum="3018" percentnew="0" expires="0" created_prectime="0x1d359bbb62ce6ba" partial="0" retentiontype="daily,weekly,monthly" backuptype="Full" ddrindex="1" locked="0" direct_restore="1" tier="3" ...
 

3. Pomocí příkazu "created_prectime" spusťte následující příkaz:  

avmgr chgt --path=/clients/clientName  --date="<created_prectime>" --tiering=0 --ava
 

Například: 

avmgr chgt --path=/clients/clientName  --date="0x1d359bbb62ce6ba" --tiering=0 --ava 

Hodnota "--tiering=0" změní umístění metadat zálohy z cloudové vrstvy na aktivní vrstvu.

4. Znovu spusťte příkaz z kroku 2 a ověřte, že záloha nyní hlásí správnou vrstvu:

avmgr getb --path=/clients/ClientName --format=xml --incpartials |grep 'labelnum="<labelnum>"' 
 

Například:  

avmgr getb --path=/clients/ClientName --format=xml --incpartials |grep 'labelnum="592"'
avmgr getb --path=/clients/ClientName --format=xml --incpartials  labelnum=592
<backuplistrec flags="24117249" labelnum="592" label="***_Exchange_Full-1510201386783#0" created="1510274087" roothash="fff989cfe0fe0654abc5453466fcbe7b12879207" totalbytes="3537383718912.00" ispresentbytes="0.00" pidnum="3018" percentnew="0" expires="0" created_prectime="0x1d359bbb62ce6ba" partial="0" retentiontype="daily,weekly,monthly"   backuptype="Full" ddrindex="1" locked="0" direct_restore="1" tier="0" ... 
 

Additional Information

Název úrovně Číslo Poznámky
Aktivní 0

Záloha je uložena v aktivní vrstvě systému Data Domain a neukládá se do cloudu.

Označen 1

Záloha je označená pro vrstvení do cloudu.

Zatímco software Avamar označuje data pro vrstvení do cloudu, skutečné operace vrstvení probíhají na základě plánu vrstvení Data Domain.

Pokud je záloha označena pro vrstvení, ale ještě nebyla vrstvena, zobrazí se ve správci systému Avamar jako označená.

Cloud 2

Záloha byla vrstvena do cloudu.

Neurčitý 3

Když server Avamar označuje zálohy pro vrstvení nebo odvolává zálohy z cloudu, má záloha stav Indeterminate.

Affected Products

Avamar, Avamar Server
Article Properties
Article Number: 000169701
Article Type: Solution
Last Modified: 08 Aug 2025
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.