Avamar: Como atualizar a referência de metadados de backup Um backup foi recuperado manualmente do Data Domain Cloud Tier

Summary: O Avamar mantém e usa metadados de backup para executar a restauração necessária no nível da nuvem para uma grade do Avamar integrada a um Data Domain. Este artigo explica como ressincronizar backups recuperados manualmente do DD e atualizar metadados do Avamar. ...

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Symptoms

O procedimento correto de recuperação para um backup do Data Domain (DD) Cloud Tier para o nível ativo usa o "avtier", conforme documentado no Avamar: Como recuperar backups que foram migrados para o Data Domain Cloud Tier.

Este artigo aborda cenários em que o procedimento correto não foi usado e a recuperação foi realizada manualmente no DD sem alterações no Avamar.

Após a recuperação manual do DD, o backup está no nível ativo do DD, mas os metadados do Avamar para o backup o mostram no nível da nuvem.

Por exemplo:

avmgr getb --path=/clients/ClientName --format=xml --incpartials | grep -i 1D359BBB62CE6BA
backuplistrec flags="24117249" labelnum="592" label="***_Exchange_Full-1510201386783#0" created="1510274087" roothash="fff989cfe0fe0654abc5453466fcbe7b12879207" 
totalbytes="3537383718912.00" ispresentbytes="0.00" pidnum="3018" percentnew="0" expires="0" created_prectime="0x1d359bbb62ce6ba" partial="0" retentiontype=
"daily,weekly,monthly" backuptype="Full" ddrindex="1" locked="0" direct_restore="1" tier="2" appconsistent="not_available" sealstate="COMPLETE"/>

(saída agrupada para facilitar a leitura)

A partir dessa saída, tier="2" indica que o Avamar ainda reconhece o backup como armazenado no Cloud Tier.

As tentativas de restaurar esse backup do Avamar causam a movimentação de novos dados (desnecessária) no DD entre os níveis ativo e de nuvem quando a recuperação é invocada.

Cause

Se um backup recuperado do Data Domain Cloud Tier para o Active Tier não tiver sido realizado pelo Avamar, os metadados desse backup no Avamar estarão fora de sincronia com a localização dos dados no Data Domain.

Resolution

Há duas soluções temporárias para corrigir isso:

Método 1: Sincronizar os metadados de backup entre GSAN e Data Domain, executando a coleta de lixo (GC) com "checkalltierduringgc" ativado:

Advertência: Nenhuma outra tarefa de manutenção pode ser executada.
 
Nota: A coleta manual de lixo pode ser executada em até 60 minutos.
 

1. Interrompa o agendador de manutenção: 

dpnctl stop maint 
 

2. Habilite a opção changealltiering parâmetro:

avmaint --ava config checkalltierduringgc=true
 

3. Inicie a coleta de lixo:

 avmaint --ava garbagecollect 
 

4. Monitore a grade até que a GC seja concluída usando um dos comandos abaixo:

avmaint gcstatus -- or -- status.dpn
 

5. Depois que a GC for concluída, desative o changealltiering parâmetro:

avmaint --ava config checkalltierduringgc=false
 

6. Reinicie o agendador de manutenção:

dpnctl start maint
 

Método 2: Atualize manualmente os metadados de backup usando "avmgr chgt":

Nota: Isso corrige o problema de disponibilizar o backup imediatamente para restauração.
 

1. Crie um checkpoint do Avamar caso ocorra algum problema.

2. Consulte o status do backup a ser recuperado do Data Domain Cloud Tier usando o comando abaixo. Registre o parâmetro "created_prectime" valor.

avmgr getb --path=/clients/ClientName --format=xml --incpartials |grep 'labelnum="<labelnum>"' 
 

Por exemplo:  

avmgr getb --path=/clients/ClientName --format=xml --incpartials |grep 'labelnum="592"'
backuplistrec flags="24117249" labelnum="592" label="***_Exchange_Full-1510201386783#0" created="1510274087" roothash="fff989cfe0fe0654abc5453466fcbe7b12879207" totalbytes="3537383718912.00" ispresentbytes="0.00" pidnum="3018" percentnew="0" expires="0" created_prectime="0x1d359bbb62ce6ba" partial="0" retentiontype="daily,weekly,monthly" backuptype="Full" ddrindex="1" locked="0" direct_restore="1" tier="3" ...
 

3. Usando o "created_prectime" acima, execute o seguinte comando:  

avmgr chgt --path=/clients/clientName  --date="<created_prectime>" --tiering=0 --ava
 

Por exemplo: 

avmgr chgt --path=/clients/clientName  --date="0x1d359bbb62ce6ba" --tiering=0 --ava 

O "--tiering=0" altera o local dos metadados de backup do nível da nuvem para o nível ativo.

4. Execute novamente o comando da etapa 2 para verificar se o backup agora relata o nível correto:

avmgr getb --path=/clients/ClientName --format=xml --incpartials |grep 'labelnum="<labelnum>"' 
 

Por exemplo:  

avmgr getb --path=/clients/ClientName --format=xml --incpartials |grep 'labelnum="592"'
avmgr getb --path=/clients/ClientName --format=xml --incpartials  labelnum=592
<backuplistrec flags="24117249" labelnum="592" label="***_Exchange_Full-1510201386783#0" created="1510274087" roothash="fff989cfe0fe0654abc5453466fcbe7b12879207" totalbytes="3537383718912.00" ispresentbytes="0.00" pidnum="3018" percentnew="0" expires="0" created_prectime="0x1d359bbb62ce6ba" partial="0" retentiontype="daily,weekly,monthly"   backuptype="Full" ddrindex="1" locked="0" direct_restore="1" tier="0" ... 
 

Additional Information

Nome do nível Número Notas
Ativa 0

O backup é armazenado no nível ativo do Data Domain e não é armazenado na nuvem.

Marcado 1

O backup é marcado para armazenamento em camadas na nuvem.

Embora o software Avamar marque dados para armazenamento em camadas na nuvem, as operações reais de armazenamento em camadas ocorrem com base no agendamento de armazenamento em camadas do Data Domain.

Quando o backup é marcado para classificação por níveis, mas ainda não foi classificado, ele é listado como marcado no Avamar Administrator.

Nuvem 2

O backup foi escalonado para a nuvem.

Indeterminado 3

Quando o servidor Avamar está marcando backups para armazenamento em camadas ou recuperando backups da nuvem, o backup tem o status Indeterminado.

Affected Products

Avamar, Avamar Server
Article Properties
Article Number: 000169701
Article Type: Solution
Last Modified: 08 Aug 2025
Version:  11
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