Avamar: Yedekleme meta verisi güncelleştirme referansı: Bir yedekleme, Data Domain Bulut Katmanı'ndan manuel olarak geri çağrıldı

Summary: Avamar, bir Data Domain ile entegre bir Avamar ızgarası için bulut katmanı geri yüklemesini gerektiğinde gerçekleştirmek için yedekleme meta verilerini korur ve kullanır. Bu makalede, DD'nin manuel olarak geri çağrılan yedeklemeleri nasıl yeniden senkronize edebileceğiniz ve Avamar Metadata'yı güncelleştirebileceğiniz açıklanmaktadır. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Data Domain (DD) Bulut Katmanından Aktif Katmana yedekleme için doğru geri çağırma prosedürü Avamar "avtier" komutu, Avamar'da belgelendiği gibi: Data Domain Bulut Katmanı'na geçirilen yedekleri geri çağırma.

Bu makalede, doğru prosedürün kullanılmadığı ve geri çağırmanın Avamar'da değişiklik yapılmadan DD üzerinde manuel olarak gerçekleştirildiği senaryolar ele alınmaktadır.

Manuel DD geri çağırma işleminden sonra yedekleme, DD aktif katmanında olur ancak yedeklemeye yönelik Avamar meta verileri bunu bulut katmanında gösterir.

Örneğin:

avmgr getb --path=/clients/ClientName --format=xml --incpartials | grep -i 1D359BBB62CE6BA
backuplistrec flags="24117249" labelnum="592" label="***_Exchange_Full-1510201386783#0" created="1510274087" roothash="fff989cfe0fe0654abc5453466fcbe7b12879207" 
totalbytes="3537383718912.00" ispresentbytes="0.00" pidnum="3018" percentnew="0" expires="0" created_prectime="0x1d359bbb62ce6ba" partial="0" retentiontype=
"daily,weekly,monthly" backuptype="Full" ddrindex="1" locked="0" direct_restore="1" tier="2" appconsistent="not_available" sealstate="COMPLETE"/>

(Çıktı, okunabilirlik için paketlenmiştir)

Bu çıktıdaki tier="2" ifadesi, Avamar'ın yedeklemeyi Cloud Tier'da depolanmış olarak hâlâ tanıdığını belirtir.

Bu yedeği Avamar'dan geri yükleme girişimleri, geri çağırma işlemi başlatıldığında aktif ve bulut katmanları arasında DD üzerinde yeni (gereksiz) veri hareketine neden olur.

Cause

Avamar tarafından Data Domain Bulut Katmanından Aktif Katmana geri çağrılan bir yedekleme işlemi gerçekleştirilmediyse Avamar'daki bu yedeklemenin meta verileri, verilerin Data Domain'deki konumuyla senkronize değildir.

Resolution

Bunu düzeltmek için iki geçici çözüm vardır:

1. Yöntem: Yedekleme meta verilerini şunlar arasında senkronize edin: GSAN ve Data Domain'i Çöp Toplama (GC) ile çalıştırarak "checkalltierduringgc" etkin:

Uyarı: Başka hiçbir bakım görevi çalıştırılamaz.
 
Not: Manuel Çöp Toplama işlemi 60 dakikaya kadar sürebilir.
 

1. Bakım zamanlayıcısını durdurun: 

dpnctl stop maint 
 

2. Etkinleştir changealltiering parametre:

avmaint --ava config checkalltierduringgc=true
 

3. Çöp toplamayı başlatma:

 avmaint --ava garbagecollect 
 

4. Aşağıdaki komutlardan birini kullanarak GC tamamlanana kadar kılavuzu izleyin:

avmaint gcstatus -- or -- status.dpn
 

5. GC tamamlandıktan sonra devre dışı bırakın changealltiering parametre:

avmaint --ava config checkalltierduringgc=false
 

6. Bakım zamanlayıcısını yeniden başlatın:

dpnctl start maint
 

2. Yöntem: " komutunu kullanarak yedekleme meta verilerini manuel olarak güncelleyinavmgr chgt":

Not: Bu işlem sorunu hemen düzeltir ve yedeklemeyi geri yükleme için kullanılabilir hale getirir.
 

1. Herhangi bir sorun oluşması ihtimaline karşı bir Avamar kontrol noktası oluşturun.

2. Aşağıdaki komutu kullanarak Data Domain Bulut Katmanından geri çağrılacak yedeğin durumunu sorgulayın. Parametreyi kaydedin "created_prectime" değeri.

avmgr getb --path=/clients/ClientName --format=xml --incpartials |grep 'labelnum="<labelnum>"' 
 

Örneğin:  

avmgr getb --path=/clients/ClientName --format=xml --incpartials |grep 'labelnum="592"'
backuplistrec flags="24117249" labelnum="592" label="***_Exchange_Full-1510201386783#0" created="1510274087" roothash="fff989cfe0fe0654abc5453466fcbe7b12879207" totalbytes="3537383718912.00" ispresentbytes="0.00" pidnum="3018" percentnew="0" expires="0" created_prectime="0x1d359bbb62ce6ba" partial="0" retentiontype="daily,weekly,monthly" backuptype="Full" ddrindex="1" locked="0" direct_restore="1" tier="3" ...
 

3. Kullanma "created_prectime" yukarıdan aşağıdaki komutu çalıştırın:  

avmgr chgt --path=/clients/clientName  --date="<created_prectime>" --tiering=0 --ava
 

Örneğin: 

avmgr chgt --path=/clients/clientName  --date="0x1d359bbb62ce6ba" --tiering=0 --ava 

--tiering=0" değeri, yedek meta veri konumunu Bulut Katmanından Aktif Katmana değiştirir.

4. Yedeklemenin artık doğru katmanı bildirdiğinden emin olmak için 2. adımdaki komutu yeniden çalıştırın:

avmgr getb --path=/clients/ClientName --format=xml --incpartials |grep 'labelnum="<labelnum>"' 
 

Örneğin:  

avmgr getb --path=/clients/ClientName --format=xml --incpartials |grep 'labelnum="592"'
avmgr getb --path=/clients/ClientName --format=xml --incpartials  labelnum=592
<backuplistrec flags="24117249" labelnum="592" label="***_Exchange_Full-1510201386783#0" created="1510274087" roothash="fff989cfe0fe0654abc5453466fcbe7b12879207" totalbytes="3537383718912.00" ispresentbytes="0.00" pidnum="3018" percentnew="0" expires="0" created_prectime="0x1d359bbb62ce6ba" partial="0" retentiontype="daily,weekly,monthly"   backuptype="Full" ddrindex="1" locked="0" direct_restore="1" tier="0" ... 
 

Additional Information

Katman Adı Numarası Notlar
Active (Etkin) 0

Yedekleme, Data Domain'in aktif katmanında depolanır ve bulutta depolanmaz.

Işaretlenmiş 1

Yedekleme, buluta katmanlama için işaretlenir.

Avamar yazılımı, buluta katmanlama için verileri işaretlerken gerçek katmanlama işlemleri Data Domain katmanlama zamanlamasına göre gerçekleşir.

Yedekleme katmanlama için işaretlenmişse ancak henüz katmanlanmamışsa Avamar Administrator'da Marked olarak listelenir.

Cloud 2

Yedekleme buluta katmanlanmıştır.

Belirsiz 3

Avamar sunucusu katmanlama için yedekleri işaretlerken veya buluttan yedekleri geri çağırırken yedeklerin durumu Indeterminate'tir.

Affected Products

Avamar, Avamar Server
Article Properties
Article Number: 000169701
Article Type: Solution
Last Modified: 08 Aug 2025
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.