Avamar: 보안 LDAP 테스트가 실패하고 다음 오류가 발생합니다. "메시지 javax.naming.ServiceUnavailableException:"

Summary: Avamar: 보안 LDAP 테스트가 실패하고 다음 오류가 발생합니다. "메시지 javax.naming.ServiceUnavailableException:"

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Symptoms



KB 문서 529493를 사용하여 사용자가 구성한 보안 LDAP: Avamar Server

에서 보안 LDAP를 구성하는 방법시나리오 1:        
LDAP 테스트가 실패하고 다음 오류가 표시됩니다.   
메시지 javax.naming.ServiceUnavailableException: dc-01.emc.com:636; 소켓 닫힘; 남은 이름 'dc=emc,dc=com'

시나리오 2:   
오류 메시지:    
2020-03-17 11:14:46,222 오류 [main]-helper. LDAPUpnGrpQueryActionUserAuth: 디렉토리 검색 문제 : javax.naming.CommunicationException : dc-01.emc.com:636 [루트 예외는 javax.net.ssl.SSLHandshakeException : sun.security.validator.ValidatorException : PKIX 경로 빌드 실패: sun.security.provider.certpath.SunCertPathBuilderException: 요청된 대상에 대한 유효한 인증 경로를 찾을 수 없음]

Cause

  • 환경에 dc-01, dc-02 등과 같은 여러 DC가 있습니다. 
  • LDAP가 하나의 DC를 사용하도록 구성되었으며 해당 DC에 대한 인증서를 rmi_ssl_keystore로 가져왔습니다. 

Resolution

단계:   
  1. 다음 KB 문서 529493에 따라 보안 LDAP를 구성합니다. Avamar Server에서 보안 LDAP를 구성하는 방법   
  2. DC가 여러 개 있는지 확인한 다음 DC 이름 및 IP를 가져옵니다.
  3. "nslookup domain name"을 사용하여 DC를 확인합니다.
예:    
nslookup dell.com
  1. DC 목록에 대한 인증서를 가져오고 LDAP 서버 인증서를 rmi_ssl_keystore로 가져옵니다. 
  2. 인증서를 가져오려면 다음 단계를 따르십시오. 
    1. PuTTY에 로그인하고 루트 사용자로 전환합니다.
    2. rmi_ssl_keystore의 백업 복제본을 만듭니다.    
cp -p /usr/local/avamar/lib/rmi_ssl_keystore /usr/local/avamar/lib/rmi_ssl_keystore-orig
  1. 환경(dc-01 및 DC-02)에 둘 이상의 DC가 있다고 가정하고 dc-01.crt 및 dc-02.crt의 인증서를 /tmp 아래에 배치합니다.
keytool -importcert -file /tmp/dc-01.crt -keystore /usr/local/avamar/lib/rmi_ssl_keystore -storepass changeme -alias dc-01
keytool -importcert -file /tmp/dc-02.crt -keystore /usr/local/avamar/lib/rmi_ssl_keystore -storepass changeme -alias dc-02
  1. 관리 사용자로 MCS를 재시작합니다.    
mcserver.sh --stop
 
 
mcserver.sh --시작



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Affected Products

Avamar

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Article Properties
Article Number: 000170123
Article Type: Solution
Last Modified: 10 Oct 2024
Version:  4
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