Avamar: Der sichere LDAP-Test schlägt mit folgendem Fehler fehl: "message javax.naming.ServiceUnavailableException:"
Summary: Avamar: Der sichere LDAP-Test schlägt mit folgendem Fehler fehl: "message javax.naming.ServiceUnavailableException:"
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Vom Nutzer konfiguriertes sicheres LDAP mithilfe von KB-Artikel 529493: Konfigurieren von sicherem LDAP auf einem Avamar-Server
Szenario 1:
LDAP-Test schlägt mit folgendem Fehler fehl:
message javax.naming.ServiceUnavailableException: dc-01.emc.com:636; Steckdose geschlossen; Verbleibender Name: "dc=emc,dc=com"
Szenario 2:
Fehlermeldung:
2020-03-17 11:14:46,222 FEHLER [main]-helper. LDAPUpnGrpQueryActionUserAuth: Problem beim Durchsuchen des Verzeichnisses: javax.naming.CommunicationException: dc-01.emc.com:636 [Root-Ausnahme ist javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX-Pfaderstellung fehlgeschlagen: sun.security.provider.certpath.SunCertPathBuilderException: gültiger Zertifizierungspfad zum angeforderten Ziel kann nicht gefunden werden]
Cause
- Es gibt mehrere DCs in der Umgebung, z. B. DC-01, DC-02 usw.
- LDAP wurde für die Verwendung eines DC konfiguriert und das Zertifikat für diesen DC wurde in rmi_ssl_keystore importiert.
Resolution
Schritte:
- Konfigurieren Sie sicheres LDAP gemäß KB-Artikel 529493: Konfigurieren von sicherem LDAP auf einem Avamar-Server
- Überprüfen Sie, ob mehrere DCs vorhanden sind, und rufen Sie dann die DC-Namen und IPs ab
- Suchen Sie mit "nslookup domain name" nach den DCs.
Zum Beispiel:
nslookup dell.com
- Abrufen von Zertifikaten für die Liste der DCs und Importieren von LDAP-Serverzertifikaten in rmi_ssl_keystore
- Führen Sie die folgenden Schritte aus, um das Zertifikat zu importieren:
- Melden Sie sich bei PuTTY an und wechseln Sie zum Root-Nutzer.
- Erstellen Sie eine Sicherungskopie von rmi_ssl_keystore:
cp -p /usr/local/avamar/lib/rmi_ssl_keystore /usr/local/avamar/lib/rmi_ssl_keystore-orig
- Unter der Annahme, dass zwei oder mehr DCs in der Umgebung vorhanden sind (DC-01 und DC-02), platzieren Sie das Zertifikat von dc-01.crt und dc-02.crt unter /tmp
keytool -importcert -file /tmp/dc-01.crt -keystore /usr/local/avamar/lib/rmi_ssl_keystore -storepass changeme -alias dc-01
keytool -importcert -file /tmp/dc-02.crt -keystore /usr/local/avamar/lib/rmi_ssl_keystore -storepass changeme -alias dc-02
keytool -importcert -file /tmp/dc-02.crt -keystore /usr/local/avamar/lib/rmi_ssl_keystore -storepass changeme -alias dc-02
- Starten Sie MCS als Admin-Nutzer neu:
mcserver.sh --stop
mcserver.sh --start
Additional Information
Diese Inhalte sind in 17 Sprachen übersetzt verfügbar:
| https://downloads.dell.com/TranslatedPDF/CS_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/DA_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/ES-XL_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/FI_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/NO-NO_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/PL_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/PT-BR_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/TR_KB541441.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_KB541441.pdf |
Affected Products
AvamarProducts
AvamarArticle Properties
Article Number: 000170123
Article Type: Solution
Last Modified: 10 Oct 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.