Avamar:セキュアLDAPテストが次のエラーで失敗します。"メッセージjavax.naming.ServiceUnavailableException:"
Summary: Avamar:セキュアLDAPテストが次のエラーで失敗します。"メッセージjavax.naming.ServiceUnavailableException:"
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Symptoms
KB記事529493を使用してユーザーがセキュアLDAPを構成したAvamarサーバーでセキュアLDAPを設定する方法を教えてください
シナリオ1:
LDAPテストが次のエラーで失敗します。
メッセージjavax.naming.ServiceUnavailableException:dc-01.emc.com:636;ソケットが閉じています。残りの名前「dc=emc,dc=com」
シナリオ2:
Error message:
2020-03-17 11:14: 46222 ERROR [main]-ヘルパー。LDAPUpnGrpQueryActionUserAuth: ディレクトリの検索中に問題が発生しました: javax.naming.CommunicationException: dc-01.emc.com:636 [ルート例外は javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIXパスの構築に失敗しました:sun.security.provider.certpath.SunCertPathBuilderException:要求されたターゲットへの有効な証明書パスが見つかりません]
Cause
- 環境内に複数のDCがあります(例:dc-01、dc-02など)。
- LDAPは1つのDCを使用するように設定され、そのDCの証明書はrmi_ssl_keystoreにインポートされました。
Resolution
手順:
- 次のKB記事529493を使用して、セキュリティで保護されたLDAPを構成します。AvamarサーバーでセキュアLDAPを設定する方法
- DCが複数あるかどうかを確認し、DC名とIPを取得します
- 「nslookupドメイン名」を使用してDCを確認します。
例:
nslookup dell.com
- DCの一覧の証明書を取得し、LDAPサーバー証明書をrmi_ssl_keystoreにインポートします
- 証明書をインポートするには、次の手順に従います。
- PuTTYにログインし、rootユーザーに切り替えます
- rmi_ssl_keystoreのバックアップ コピーを作成します。
cp -p /usr/local/avamar/lib/rmi_ssl_keystore/usr/local/avamar/lib/rmi_ssl_keystore-orig
- 環境(dc-01とdc-02)に2つ以上のDCがあると仮定して、dc-01.crtとdc-02.crtの証明書を/tmpに配置します
keytool -importcert -file /tmp/dc-01.crt -keystore /usr/local/avamar/lib/rmi_ssl_keystore -storepass changeme -alias dc-01
keytool -importcert -file /tmp/dc-02.crt -keystore /usr/local/avamar/lib/rmi_ssl_keystore -storepass changeme -alias dc-02
keytool -importcert -file /tmp/dc-02.crt -keystore /usr/local/avamar/lib/rmi_ssl_keystore -storepass changeme -alias dc-02
- 管理者ユーザーとしてMCSを再起動します。
mcserver.sh --stop
mcserver.sh --start
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Affected Products
AvamarProducts
AvamarArticle Properties
Article Number: 000170123
Article Type: Solution
Last Modified: 10 Oct 2024
Version: 4
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