Avamar:安全 LDAP 测试失败,并显示错误:“message javax.naming.ServiceUnavailableException:”

Summary: Avamar:安全 LDAP 测试失败,并显示错误:“message javax.naming.ServiceUnavailableException:”

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



用户已使用知识库文章 529493 配置安全 LDAP:如何在 Avamar Server

上配置安全 LDAP情况 1:        
LDAP 测试失败,并显示错误:   
消息 javax.naming.ServiceUnavailableException: dc-01.emc.com:636;插座闭合;剩余名称“dc=emc,dc=com”

情况 2:   
错误消息:    
2020-03-17 11:14:4622 ERROR [main]-helper.LDAPUpnGrpQueryActionUserAuth:Problem searching directory: javax.naming.CommunicationException: dc-01.emc.com:636 [Root exception is javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException:PKIX 路径构建失败:sun.security.provider.certpath.SunCertPathBuilderException:找不到所请求目标的有效认证路径]

Cause

  • 环境中有多个 DC,例如 dc-01、dc-02 等。 
  • LDAP 配置为使用一个 DC,并将该 DC 的证书导入到 rmi_ssl_keystore。 

Resolution

步骤:   
  1. 按照以下知识库文章529493配置安全 LDAP:如何在 Avamar Server 上配置安全 LDAP   
  2. 验证是否有多个 DC,然后获取 DC 名称和 IP
  3. 使用“nslookup 域名”检查 DC。
例如:    
nslookup dell.com
  1. 获取 DC 列表的证书并将 LDAP 服务器证书导入到 rmi_ssl_keystore 
  2. 要导入证书,请执行以下步骤: 
    1. 登录到 PuTTY 并切换到 root 用户
    2. 创建 rmi_ssl_keystore 的备份副本:    
cp -p /usr/local/avamar/lib/rmi_ssl_keystore /usr/local/avamar/lib/rmi_ssl_keystore-orig
  1. 假设环境中有两个或更多 DC(dc-01 和 DC-02),将 dc-01.crt 和 dc-02.crt 的证书置于 /tmp 下
keytool -importcert -file /tmp/dc-01.crt -keystore /usr/local/avamar/lib/rmi_ssl_keystore -storepass changeme -alias dc-01
keytool -importcert -file /tmp/dc-02.crt -keystore /usr/local/avamar/lib/rmi_ssl_keystore -storepass changeme -alias dc-02
  1. 以管理员用户身份重新启动 MCS:    
mcserver.sh --stop
 
 
mcserver.sh --start



Additional Information

此内容已翻译成 17 种语言: 
https://downloads.dell.com/TranslatedPDF/CS_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/DA_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/DE_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/FI_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/FR_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/IT_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/JA_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/KO_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/NL_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/NO-NO_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/PL_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/RU_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/SV_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/TR_KB541441.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_KB541441.pdf

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000170123
Article Type: Solution
Last Modified: 10 Oct 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.