Avamar: How to use remote MCCLI server to manage multiple Avamar which are using signed MCSSL cert

Summary: How to use remote MCCLI server to manage multiple Avamar which are using signed MCSSL cert.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Signed certificate was installed using AUI which changed MCSSL cert to signed cert.

Note: This KB article is applicable for Avamar 19.2.x and 18.2.x only. This article should not be applied to previous Avamar versions.

If the MCSSL certificate is changed to a signed certificate, (see KB article 540434: Avamar 19.2: How to install CA Signed certificate using AUI), remote MCCLI server stopped working with below error:

1,23996,CLI failed to connect to MCS.
Attribute Value
--------- -------------------------------------------------------------------------------------------------------------------------------------------------
reason    FIPS 140-2 mode is not supported on Java 7.  Please install supported version of Java on the client machine, or turn off this mode on the server.
option    non-JRMP server at remote endpoint

 

Cause

Remote MCCLI server does not contain correct chain certs (root and intermediate cert) for Avamar server.

 

Resolution

  1. Log in to the remote MCCLI server and switch to the MCCLI install directory. For example:

    cd /usr/local/avamar/19.2.0-155/lib
  2. Take a backup copy of the existing rmi_ssl_keystore:

    cp -p rmi_ssl_keystore rmi_ssl_keystore-orig
  3. Import Chain certs which contain root and intermediate certs for CA (assuming you have received ca.crt from CA):

    keytool -importcert -file ca.crt -alias rootcert -keystore /usr/local/avamar/19.2.0-155/lib/rmi_ssl_keystore -storepass changeme
  4. Try an MCCLI command from a remote MCCLI server to test. It should work now.

 

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000170139
Article Type: Solution
Last Modified: 07 Nov 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.