RecoverPoint: Upgrade to 5.1.x fails with error - "Operation failed. nullXParam error - while parsing assignment to parameter 'wwn':..."

Summary: Upgrade to RecoverPoint 5.1.x fails with error - "Operation failed. nullXParam error - while parsing assignment to parameter 'wwn':..."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Upgrade RecoverPoint from 5.0.x to 5.1.x

RecoverPoint DM upgrade from 5.0.x to 5.1.x fails with errors in dm.log:
2018-03-03 19:44:39,960 [pool-1-thread-65] (InstallationServerClientImpl.java:1113) ERROR - Transaction number 47 failed. Operation failed. nullXParam error - while parsing assignment to parameter 'wwn':
no conversion path found from TentativeLiteral
( 21190904897895456230238393799081591957782628508405xxxxxxxx )  to ulonglong

2018-03-03 19:44:39,960 [pool-1-thread-65] (BaseDMCommand.java:150) ERROR - AutoUpgradeCheckNewBoxAndApplyPhaseCommand FAILED
com.emc.dm.exception.InstallationCommException: Operation failed. nullXParam error - while parsing assignment to parameter 'wwn':
no conversion path found from TentativeLiteral
( 21190904897895456230238393799081591957782628508405xxxxxxxx )  to ulonglong

 

Cause

The root cause is still being investigated by RP Engineering.
However, we can see that in the settings of the RPAs upgraded to 5.1 (fezick settings) the WWNs were converted wrongly and DM and Installation server on the RPAs cannot apply the settings on the RPAs due to this.

This appears to occur only on RPAs that were previously replaced, but it does not occur on all RPAs being replaced.

Resolution

Workaround:

A solution exists for this issue but intervention from Dell EMC technical support personnel is required. An SME will need to examine internal RPA WWN spoofing settings (fezick), convert them and then DM upgrade can be retried. Contact the Dell EMC Customer Support Center or your service representative for technical assistance and reference this Dell EMC knowledgebase solution ID.

Resolution:


This issue is resolved in RecoverPoint 5.1.2.
Upgrades to RecoverPoint 5.1.2 will not suffer from the issue, therefore its highly recommended to upgrade to 5.1.2 and not 5.1.0.x on physical appliances

 

Affected Products

RecoverPoint

Products

RecoverPoint
Article Properties
Article Number: 000170738
Article Type: Solution
Last Modified: 11 Jun 2025
Version:  4
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