SourceOne для файловых систем: Действие "Файловый архив - Исторический" завершается сбоем с ошибкой "XML parsing: строка 2"

Summary: SourceOne для файловых систем: Действие SourceOne «Файловый архив — Архив» завершается сбоем с ошибкой «Синтаксический анализ XML: строка 2, символ 1061, недопустимый символ xml Собственная ошибка: 9420 Состояние SQL: 42000" ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Исходное задание файлового архива (JBS) завершается сбоем при создании дочерних заданий (JBC) на основе источников данных, выбранных при создании действия «Архив файлов — История».
Если родительское задание должно было создать много заданий, некоторые дочерние задания уже начали обрабатываться до возникновения проблемы.
Родительские и дочерние задания прекращают обработку, так как диспетчерская служба заданий SourceOne дала указание заданиям остановиться после возникновения ошибки.

Сообщение об ошибке, подобное следующему, будет найдено в SOFileArchiveJBS.log подробном файле журнала на рабочем сервере SourceOne, который обрабатывает родительское задание для действия, завершившегося сбоем:

95216|P2D0|T1274|2017/04/13 23:18:46:531|CoExTask::Save|ERROR|System call failed. (0x86040100) [SOFileArchiveJBS, CoExTask.cpp(947).CoExTask::Save] >System call failed. (0x86040100) [SOFileArchiveJBS, CoExJDFDB.cpp(905).CoExJDFDB::ExecuteCmdForID] >System call failed. (0x86040100) [SOFileArchiveJBS, CoExJDFDB.h(514).CoExJDFDB::ExecuteSP] >System call failed. (0x86040100) Unknown error (0x800424CC) [SOFileArchiveJBS, CoExJDFDB.h(509).CoExJDFDB::ExecuteSP] >{XML parsing: line 2, character 1061, illegal xml character Native error: 9420 SQL State: 42000 } |CoExTask.cpp(947)|Job Id: 209023; Activity Name: FileShareProcessing; Activity Id: 10159; Activity Type: -1788567307; ES1WORKER


 

Cause

В файловой системе, проверенной родительским заданием архива файлов SourceOne, присутствует неправильно сформированное имя папки.
Эта папка становится частью XML и сохраняется в базе данных действий SourceOne для создания дочернего задания.
Сохранение XML в базе данных действий завершается сбоем с сообщением об ошибке, упомянутым в разделе о проблеме выше.

Resolution

Определите и переименуйте папку, вызывающую проблему.

Чтобы определить имя папки, вызывающее проблему, выполните следующие действия.

  1. На рабочем сервере (серверах) SourceOne с ролью "File Archive - Historical" измените уровень детализации для компонента SOFileArchiveJBS на 8 (десятичный). Чтобы изменить его, выполните следующие действия.  
    • Запуск редактора реестра (regedit.exe)
    • Перейдите в раздел «HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\EMC\SourceOne\TraceLogs\SOFileArchiveJBS\Settings»
    • Изменить значение TraceVerbosity до 8 (десятичная).
    • Закройте редактор реестра
  2. Создание/запуск действия «Архив файлов — Архив», которое завершается сбоем с вышеупомянутым сообщением об ошибке. 
  3. Если родительские задания, созданные действием из шага 2, помечены состоянием сбоя, откройте файл SOFileArchiveJBS.log на рабочем сервере SourceOne, который обработал сбойное родительское задание.
  4. Начиная с нижнего угла, где вы заполняете сообщение об ошибке поиска, упомянутое ниже, начните поиск папок, которые были недавно проверены SOFileArchiveJBS.exe процессом. Вы должны найти папку со странным именем, похожую на следующую:
2077389|P2D0|T1274|2017/04/13 23:18:43:894|CSOFileArchiveJBS::ScanCurrentDirectory|VERBOSE|Push for path: \\?\UNC\LabMachine\E$\katwar\Downloads\       , index: 206912|SOFileArchiveJBS.cpp(3112)|Job Id: -1; Activity Name: ES1Worker; Activity Id: -1; Activity Type: -1; ES1WORKER
  1. Переименуйте папку, указанную на шаге 4, и повторно запустите действие, выполнение которого завершилось сбоем.

Affected Products

SourceOne for File Systems

Products

SourceOne, SourceOne for File Systems
Article Properties
Article Number: 000171396
Article Type: Solution
Last Modified: 02 Sept 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.