NVP-vProxy: SQL Server Backup login fails as it does not have the sysadmin role assigned
Summary: SQL virtual machine (VM) backups performed with the NetWorker VMware Protection (NVP) vProxy appliance fail indicating "NT AUTHORITY\SYSTEM does not have the sysadmin role assigned."
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The NetWorker VMware Protection integration is configured with the vProxy Appliance. The Microsoft Virtual Machine Application Agent (MSVMAPPAGENT) for SQL Server application-consistent protection is being used to perform a backup of a VM with Microsoft SQL Server. The VM backup fails, indicating that the "NT AUTHORITY\SYSTEM" does not have the sysadmin role assigned.
The backup session log shows:
The backup session log shows:
YYYY-MM-DD HH:MM:SS ERROR: [127] MSSQL: MSSQL:validate_application: NetWorker VM agent for Microsoft Applications: Unable to execute discovery command, error: 'The login 'NT AUTHORITY\SYSTEM' for SQL instance [VM_NAME] does not have the sysadmin role assigned.'
Cause
The MSVMAPPAGENT runs under the "NT AUTHORITY\SYSTEM" account, and it does not have sufficient rights to perform data protection operations.
Resolution
The MSVMAPPAGENT "Software and security requirements" section of the Dell NetWorker VMware Integration Guide indicates the sysadmin role must be granted to the "NT AUTHORITY\SYSTEM" account. Here is an overview of the steps to grant the permissions to the "NT AUTHORITY\SYSTEM" account.
- On the SQL VM, Open Microsoft SQL Server Management Studio.
- Connect to the SQL Server instance.
NOTE: The steps must be performed against all SQL Server instances on the VM.
- In the Object Explorer tree view, expand "Security > Logins."
- Open the Properties for the "NT AUTHORITY\SYSTEM" account.
Figure 1: SQL Server Management Studio (SSMS) Security Logins
- In the Login Properties windows, select "Server Roles" in the left pane.
- In the right pane, select "sysadmin."
- Select OK to close the Login Properties Window.
Figure 1: SSMS NT AUTHORITY\SYSTEM login properties
Article Properties
Article Number: 000173347
Article Type: Solution
Last Modified: 17 Nov 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.