Dell Unity: Opdrachttime-outfouten op de schijf kunnen leiden tot prestatieproblemen en niet-beschikbaarheid van data (op te lossen door gebruiker)

Summary: Impactbeschrijving: Ernstig prestatieprobleem nadat flash-stations beginnen met het registreren van fouten die niet automatisch door de array worden opgelost.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Mogelijke niet-beschikbaarheid van data
Ernst: Kritiek

De systeembeheerder constateert ernstige prestatieproblemen op de array nadat een schijf is gestart met het registreren van fouten - soft mediafouten en 01|18|ff gevolgd door incidentele afbrekingen, time-outs voor geselecteerde services en time-outs voor opdrachten.

Schijven met de onderdeelnummers en firmware die worden vermeld. Het array kan fouten rapporteren als "Soft media error" als 01|18|ff gevolgd door zachte SCSI-busfouten “[IncidentalAbort]", “[Select timeout]", and “[Command timeout]". De schijf kan bij de ene SP offline worden gehaald, maar bij de tweede SP actief blijven en vergelijkbare fouten melden.


Voorbeeld van SP-logs:

>>> drive repeatedly reports 01/18/ff
B       11/15/20 18:05:31.994 Bus0 Enc0 Dsk02   11c4004 [WARN] System: Disk 0_0_2 Soft media error. DrvErrExtStat:0x22 SRT 35ms ST 0x767fd102672 ET 0x767fd10b014 . [Recovered error (on-drive ECC)]
B       11/15/20 18:05:32.009 Bus0 Enc0 Dsk02   11c0006 [INFO] System: Disk 0_0_2 01|18|ff BLBA 0x32d948218 OP 0x88, LBA 0x32d948200, SZ 0x80 .
A       11/15/20 18:06:18.548 Bus0 Enc0 Dsk02   11c4004 [WARN] System: Disk 0_0_2 Soft media error. DrvErrExtStat:0x22 SRT 66ms ST 0x7680628d0f1 ET 0x7680629d1c6 . [Recovered error (on-drive ECC)]
A       11/15/20 18:06:18.566 Bus0 Enc0 Dsk02   11c0006 [INFO] System: Disk 0_0_2 01|18|ff BLBA 0x2d6cce4d8 OP 0x88, LBA 0x2d6cce4d0, SZ 0x10 .

>>> followed by Soft SCSI bus errors (Incidental abort and selection timeout)
A       11/15/20 18:17:33.877 Bus0 Enc0 Dsk02   11c4003 [WARN] System: Disk 0_0_2 Soft SCSI bus error. DrvErrExtStat:0xdd SRT 522ms ST 0x7682e5dd934 ET 0x7682e65cf8b . [IncidentalAbort]
B       11/15/20 18:17:33.892 Bus0 Enc0 Dsk02   11c4003 [WARN] System: Disk 0_0_2 Soft SCSI bus error. DrvErrExtStat:0xdd SRT 535ms ST 0x768280ad284 ET 0x7682812faab . [IncidentalAbort]
A       11/15/20 18:17:33.910 Bus0 Enc0 Dsk02   11c4003 [WARN] System: Disk 0_0_2 Soft SCSI bus error. DrvErrExtStat:0x7 SRT 537ms ST 0x7682e5d9c09 ET 0x7682e65cfc5 . [Select timeout]

>>> followed by repeated command timeout.
A       11/15/20 20:44:30.049 Bus0 Enc0 Dsk02   11c4003 [WARN] System: Disk 0_0_2 Soft SCSI bus error. DrvErrExtStat:0x6 SRT 4340ms ST 0x76a3b63f4df ET 0x76a3ba4175c . [Command timeout]
A       11/15/20 20:44:30.069 Bus0 Enc0 Dsk02   11c4003 [WARN] System: Disk 0_0_2 Soft SCSI bus error. DrvErrExtStat:0x6 SRT 4201ms ST 0x76a3b641f27 ET 0x76a3ba41b53 . [Command timeout]
A       11/15/20 20:44:30.090 Bus0 Enc0 Dsk02   11c4003 [WARN] System: Disk 0_0_2 Soft SCSI bus error. DrvErrExtStat:0x6 SRT 4210ms ST 0x76a3b63e5a2 ET 0x76a3ba41f97 . [Command timeout]

>>> drive reported too many port errors and was logged out, then it could not log in again. It failed on SPB with the Activate timer expired.
B       11/16/20 05:52:47.360 Bus0 Enc0 LccB    1678052 [ERROR] System: LCC is faulted. This failure may be caused by a component other than the LCC (Drive, Cable, Connector, ...).
B       11/16/20 05:54:42.263 Bus0 Enc0 Dsk02     60258 [CRIT] User: Disk 0_0_2 has failed (Part Number 005053578, Serial Number 50L0A01FTT2F)
B       11/16/20 05:54:42.879 Bus0 Enc0 LccB      602bc [CRIT] User: LCC has faulted (Part Number 303-396-000B-00, Serial Number CF2DD201400245)
B       11/16/20 05:55:23.571 Bus0 Enc0 Dsk02   1678058 [ERROR] System: Disk 0_0_2 taken offline. Escalate to support. SN:50L0A01FTT2F TLA:005053578 Rev:PA5H (0x2030001) Reason:Expired.




Systemen waarop dit probleem zich kan voordoen:

Product (en versie) Dell Unity 300F, Dell Unity 350F, Dell Unity XT 380F, Dell Unity 400F, Dell Unity 450F, Dell Unity XT 480F, Dell Unity 600F, Dell Unity 650F, Dell Unity XT 680F, Dell Unity XT 880F, Dell Unity reeks |Dell Unity All-Flash
Met deze kernsoftware
(besturingssysteem (OS) of besturingsomgeving (OE))
Alle besturingsomgevingen
Wanneer deze voorwaarde waar is Array bevat een of meer van de volgende onderdeelnummers van de schijf met firmware PA5H
005052867, 005052866, 005052869, 005052868, 005052871, 005052870, 005053573, 005053572, 005053577, 005053576, 005053579, 005053578, 005052859, 005052858, 005052861, 005052860, 005052863, 005052862, 005053583, 005053582, 005053596, 005053595, 005053598, 005053597, 005053575, 005053574

 

Cause

Bij schijven met veel datafouten wordt intern foutherstel uitgevoerd en in combinatie met lange opdrachten kan de time-outinstelling in de firmware leiden tot prestatieproblemen voor de schijf

Het ingebouwde foutherstel van de schijven wordt normaal gesproken binnen acceptabele tijdslimieten uitgevoerd, maar als gevolg van een NAND-defect zijn er in sommige gevallen veel blokken nodig voor het herstel. In combinatie met lange opdrachten kunnen time-outinstellingen leiden tot te veel time-outs van opdrachten en de prestaties van de array beïnvloeden.

Resolution

Type actie Resolutie
Vereiste actie Upgrade de schijffirmware naar PA5L om het probleem op te lossen.
Wie kan de actie uitvoeren Klant
Probleem opgelost in dit besturingssysteem, deze besturingsomgeving of software

Firmware PA5L beschikbaar op www.dell.com/support in Unity-schijffirmwarebundel V18 of hoger.

 

Oplossingsprocedure voor SolVe klant Voor meer informatie over het upgraden van schijffirmware, selecteert u 'Software Upgrade Procedures' in SolVe voor Dell Unity. 

of volg het artikel Instructies en informatie voor het upgraden van schijffirmware
Details van de oplossing Arrays die momenteel prestatieproblemen ondervinden:  Om de prestatieproblemen onmiddellijk op te lossen, moet u de foutieve schijf uit de groep halen. Zodra de schijf uit de groep is, moeten de prestaties onmiddellijk verbeteren.  Ga als volgt te werk:
Als fysieke toegang tot het systeem beschikbaar is:
Verwijder de schijf die is geïdentificeerd als een rapporterende Soft SCSI-busfout en [Command timeout]
Verwissel de verwijderde schijf door een gelijkwaardige reserveschijf.  Wacht 5 minuten voordat u de vervangende schijf plaatst om het systeem vanuit pariteit opnieuw te laten opbouwen op de vervangende schijf.
Neem indien nodig contact op met de technische support van Dell om een vervangende schijf aan te vragen voor de schijf die de prestatieproblemen veroorzaakt.
Als er niet onmiddellijk fysieke toegang tot het systeem beschikbaar is en voor het bespreken van andere mogelijke tijdelijke oplossingen, neemt u contact op met Dell Technische Support of een geautoriseerde servicevertegenwoordiger en vermeldt u dit DTA-artikelnummer.
Upgrade de schijffirmware naar PA5L.
Zorg ervoor dat nieuwe array wordt geïnstalleerd upgrade naar schijffirmware PA5L
OPMERKING:
De PA5L-firmware is bedoeld om schijven die te veel 01/18/ff- en opdrachttime-outfouten rapporteren, sneller te vervangen. Houd er rekening mee dat een secundaire prestatie-impact kan optreden tijdens het vervangen van een schijfvervanging, opnieuw opbouwen of herschikken/herverdelen in dynamic pools. LKB 000055614 wordt dienovereenkomstig bijgewerkt wanneer dit probleem is opgelost.

Raadpleeg de LKB 000021322 voor instructies voor het bijwerken van de schijffirmware.
Unity bundels met schijffirmware zijn beschikbaar om te downloaden via www.dell.com/support. Deze zijn te vinden door te zoeken naar "Unity Drive Firmware Package".

Affected Products

Dell EMC Unity Family
Article Properties
Article Number: 000190983
Article Type: Solution
Last Modified: 27 Mar 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.