Dell Unity: Błędy limitu czasu polecenia dysku mogą powodować problemy z wydajnością i niedostępność danych (możliwość korekty z poziomu użytkownika)
Summary: Opis wpływu: Poważny problem z wydajnością po uruchomieniu rejestrowania błędów dysków flash, które nie są automatycznie rozwiązywane przez macierz.
Symptoms
Potencjalna niedostępność danych
Stopień: Krytyczny
administrator systemu zauważa poważne problemy z wydajnością macierzy po tym, jak dysk zaczyna rejestrować błędy — błędy nośnika programowego i 01|18|ff, po których następują przypadkowe przerwania, przekroczenie limitu czasu wyboru i limit czasu polecenia.
Dyski z wymienionymi numerami części i oprogramowaniem sprzętowym. Macierz może zgłaszać błędy, jak: "Soft media error" i 01|18|ff po którym następują miękkie błędy magistrali SCSI “[IncidentalAbort]", “[Select timeout]", and “[Command timeout]". Dysk może zostać przełączony w tryb offline na jednym SP, ale pozostać aktywny na drugim SP, zgłaszając podobne błędy.
Przykładowe dzienniki SP:
>>> drive repeatedly reports 01/18/ff B 11/15/20 18:05:31.994 Bus0 Enc0 Dsk02 11c4004 [WARN] System: Disk 0_0_2 Soft media error. DrvErrExtStat:0x22 SRT 35ms ST 0x767fd102672 ET 0x767fd10b014 . [Recovered error (on-drive ECC)] B 11/15/20 18:05:32.009 Bus0 Enc0 Dsk02 11c0006 [INFO] System: Disk 0_0_2 01|18|ff BLBA 0x32d948218 OP 0x88, LBA 0x32d948200, SZ 0x80 . A 11/15/20 18:06:18.548 Bus0 Enc0 Dsk02 11c4004 [WARN] System: Disk 0_0_2 Soft media error. DrvErrExtStat:0x22 SRT 66ms ST 0x7680628d0f1 ET 0x7680629d1c6 . [Recovered error (on-drive ECC)] A 11/15/20 18:06:18.566 Bus0 Enc0 Dsk02 11c0006 [INFO] System: Disk 0_0_2 01|18|ff BLBA 0x2d6cce4d8 OP 0x88, LBA 0x2d6cce4d0, SZ 0x10 . >>> followed by Soft SCSI bus errors (Incidental abort and selection timeout) A 11/15/20 18:17:33.877 Bus0 Enc0 Dsk02 11c4003 [WARN] System: Disk 0_0_2 Soft SCSI bus error. DrvErrExtStat:0xdd SRT 522ms ST 0x7682e5dd934 ET 0x7682e65cf8b . [IncidentalAbort] B 11/15/20 18:17:33.892 Bus0 Enc0 Dsk02 11c4003 [WARN] System: Disk 0_0_2 Soft SCSI bus error. DrvErrExtStat:0xdd SRT 535ms ST 0x768280ad284 ET 0x7682812faab . [IncidentalAbort] A 11/15/20 18:17:33.910 Bus0 Enc0 Dsk02 11c4003 [WARN] System: Disk 0_0_2 Soft SCSI bus error. DrvErrExtStat:0x7 SRT 537ms ST 0x7682e5d9c09 ET 0x7682e65cfc5 . [Select timeout] >>> followed by repeated command timeout. A 11/15/20 20:44:30.049 Bus0 Enc0 Dsk02 11c4003 [WARN] System: Disk 0_0_2 Soft SCSI bus error. DrvErrExtStat:0x6 SRT 4340ms ST 0x76a3b63f4df ET 0x76a3ba4175c . [Command timeout] A 11/15/20 20:44:30.069 Bus0 Enc0 Dsk02 11c4003 [WARN] System: Disk 0_0_2 Soft SCSI bus error. DrvErrExtStat:0x6 SRT 4201ms ST 0x76a3b641f27 ET 0x76a3ba41b53 . [Command timeout] A 11/15/20 20:44:30.090 Bus0 Enc0 Dsk02 11c4003 [WARN] System: Disk 0_0_2 Soft SCSI bus error. DrvErrExtStat:0x6 SRT 4210ms ST 0x76a3b63e5a2 ET 0x76a3ba41f97 . [Command timeout] >>> drive reported too many port errors and was logged out, then it could not log in again. It failed on SPB with the Activate timer expired. B 11/16/20 05:52:47.360 Bus0 Enc0 LccB 1678052 [ERROR] System: LCC is faulted. This failure may be caused by a component other than the LCC (Drive, Cable, Connector, ...). B 11/16/20 05:54:42.263 Bus0 Enc0 Dsk02 60258 [CRIT] User: Disk 0_0_2 has failed (Part Number 005053578, Serial Number 50L0A01FTT2F) B 11/16/20 05:54:42.879 Bus0 Enc0 LccB 602bc [CRIT] User: LCC has faulted (Part Number 303-396-000B-00, Serial Number CF2DD201400245) B 11/16/20 05:55:23.571 Bus0 Enc0 Dsk02 1678058 [ERROR] System: Disk 0_0_2 taken offline. Escalate to support. SN:50L0A01FTT2F TLA:005053578 Rev:PA5H (0x2030001) Reason:Expired.
Systemy, których może dotyczyć ten problem:
| Produkt (i wersja) | Dell Unity 300F, Dell Unity 350F, Dell Unity XT 380F, Dell Unity 400F, Dell Unity 450F, Dell Unity XT 480F, Dell Unity 600F, Dell Unity 650F, Dell Unity XT 680F, Dell Unity XT 880F, rodzina Dell Unity |Dell Unity All Flash |
| Uruchamianie tego podstawowego oprogramowania (systemu operacyjnego (OS) lub środowiska operacyjnego (OE)) |
Wszystkie środowiska systemu operacyjnego |
| Gdy ten warunek jest spełniony | Macierz zawiera dowolny z następujących numerów części dysku z oprogramowaniem wewnętrznym PA5H : 005052867, 005052866, 005052869, 005052868, 005052871, 005052870, 005053573, 005053572, 005053577, 005053576, 005053579, 005053578, 005052859, 005052858, 005052861, 005052860, 005052863, 005052862, 005053583, 005053582, 005053596, 005053595, 005053598, 005053597, 005053575, 005053574 |
Cause
Wbudowane odzyskiwanie po błędzie dysku zwykle reaguje w dopuszczalnych limitach czasu, jednak czasami z powodu wady NAND liczba bloków wymaganych do odzyskania może być duża i w połączeniu z długim poleceniem, ustawienia limitu czasu mogą spowodować nadmierne limity czasu polecenia i wpłynąć na wydajność macierzy.
Resolution
| Typ działania | Rozwiązanie |
| Wymagane działanie | Aktualizuj oprogramowanie układowe dysku do PA5L, aby rozwiązać ten problem. |
| Kto może wykonać działanie | Klient |
| Problem w tym systemie operacyjnym, środowisku operacyjnym lub oprogramowaniu |
Oprogramowanie wewnętrzne PA5L jest dostępne w przypadku www.dell.com/support w pakiecie firmowym napędów Unity w wersji 18 lub nowszej.
|
| Procedura rozwiązywania problemu przez klienta SolVe | Aby uzyskać dodatkowe informacje na temat uaktualniania oprogramowania wewnętrznego dysków, wybierz opcję "Software Upgrade Procedures" w SolVe dla Dell Unity. lub postępuj zgodnie z artykułem Instrukcje i informacje dotyczące aktualizacji oprogramowania wewnętrznego dysku |
| Szczegółowe informacje o rozwiązaniu | Macierze, w których występują obecnie problemy z wydajnością: Aby natychmiast rozwiązać problemy z wydajnością, wyjmij dysk powodujący problem z puli. Gdy dysk jest poza pulą, wydajność powinna natychmiast ulec poprawie. Aby to osiągnąć: Jeśli fizyczny dostęp do systemu nie jest możliwy: Usuń dysk zidentyfikowany jako zgłaszający błąd magistrali Soft SCSI i [Limit czasu polecenia] Wymień usunięty dysk na równoważny dysk zapasowy. Nie należy wkładać zamiennego dysku przez 5 minut, aby umożliwić systemowi odbudowanie z parzystości do poziomu dysku zamiennego. W razie potrzeby skontaktuj się z działem pomocy technicznej firmy Dell, aby poprosić o wymianę dysku powodującego problemy z wydajnością. W przypadku braku natychmiastowego fizycznego dostępu do systemu oraz w celu omówienia innych możliwych obejść, należy skontaktować się z działem pomocy technicznej firmy Dell lub autoryzowanym przedstawicielem serwisu, podając numer tego artykułu DTA. Aktualizacja oprogramowania układowego dysku do PA5L. Upewnij się, że nowa macierz instaluje aktualizację oprogramowania wewnętrznego dysku PA5L UWAGA: Oprogramowanie wewnętrzne PA5L służy do szybszej wymiany dysków zgłaszających nadmierną ilość błędów 01/18/ff i limit czasu polecenia. Należy pamiętać, że dodatkowy wpływ na wydajność może wystąpić podczas operacji wymiany dysku lub przetasowania/równoważenia w pulach dynamicznych. 000055614 LKB zostanie odpowiednio zaktualizowany, gdy ten problem zostanie rozwiązany. Instrukcje dotyczące aktualizacji oprogramowania wewnętrznego dysku można znaleźć w 000021322 LKB. Pakiety oprogramowania układowego dysku Unity są dostępne do pobrania na stronie www.dell.com/support. Można je znaleźć, wyszukując hasło „Pakiet oprogramowania układowego dysku Unity”. |