Monitor Drops LAN Connectivity
Summary: This article describes what to do when your Dell monitor drops its RJ45 LAN connection intermittently while connected to your Dell computer.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Monitor Drop LAN Connectivity
You may find your monitor drops its LAN connection when it remains inactive for a few minutes. Or your LAN drivers are updating repeatedly through Windows Update automatically.
Affected Platforms:
- All PC platforms.
- Dell monitors with RJ45 LAN connectors.
Cause
The monitor may require a Realtek driver update.
Resolution
Updating to the latest Realtek driver for the monitor helps resolve the issue. To download and install the latest driver, browse to https://www.dell.com/support/home, enter your monitors' service tag, and download the latest Realtek Ethernet LAN Driver.
How to reinstall/install the Lan driver manually:
- Go to computer Device Manager.
- Select Network adapters.
- Find Realtek USB GbE Family Controller, right-click Properties.
- Click Uninstall Device, then check Delete the driver software for the device. Then click Uninstall at the bottom. (See Figure.1)

Figure 1: Uninstall Driver - Click OK to Uninstall Drivers until you see 10.5.xxxx.
- Click the new driver and ensure you select "Remove" to completely uninstall the features, then move on to the installation. (See Figure.2)

Figure 2: Remove Driver
Affected Products
Alienware, Inspiron, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Fixed Workstations, Mobile Workstations, Surface Pro 4Article Properties
Article Number: 000196925
Article Type: Solution
Last Modified: 22 Apr 2025
Version: 16
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