NWUI: Getting error with "Error in fetching count of activities based on status from Monitoring service"

Summary: NWUI: Getting error with "Failed to fetch latest counts for Dashboard and Error in fetching count of activities based on status from Monitoring service."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker Web User Interface (NWUI) shows:

Failed to fetch latest counts for Dashboard and Error in fetching count of activities based on status from Monitoring service.

 

From nwui.log:
Linux: /nsr/authc/logs/nwui.log
Windows: C:\Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs\nwui.log

17:00:15.942 [https-jsse-nio-9090-exec-7] ERROR c.e.n.c.n.i.MonitoringApi - Error in fetching count of activities based on status from Monitoring Service. java.net.ConnectException: Connection refused (Connection refused)

 

From monitoring-app.log:
Linux: /nsr/nwui/monitoring/app/logs/monitoring-app.log
Windows: C:\Program Files\EMC NetWorker\nwui\monitoring\app\logs\monitoring-app.log

Workflow table - deleting records older than 2023-01-26 07:13:25 2023-03-27 19:13:25.055 [CustomWorkflowRepositoryImpl] [networkerRabbitReconnectThread1] INFO Monitoring - Workflow table - No of records deleted: 0 2023-03-27 19:13:25.058 [CustomActionRepositoryImpl] [networkerRabbitReconnectThread1] INFO Monitoring - Action table - deleting records older than 2023-01-26 07:13:25 2023-03-27 19:13:25.061 [CustomActionRepositoryImpl] [networkerRabbitReconnectThread1] INFO Monitoring - Action table - No of records deleted: 0

 

Cause

Port 9095 is not listening on the NWUI server.

 

Resolution

  1. NWUI services are in running state.
    Windows: tasklist | findstr nwui
    Linux: ps -ef | grep nwui

  2. NWUI ports are either not open or not listening:

    Linux:

    # netstat -ano | grep 9095
    # netstat -ano | grep 5435

    Windows:

    > netstat -ano | findstr 9095
    > netstat -ano | findstr 5435

 

NOTE: Ports 9095 and 5435 are needed for NWUI to communicate with the Backup server. If these ports are not open or not listening, engage with your operating system or network team to review the NetWorker server's operating system firewall, and any network firewalls which may be blocking this communication.

 

Affected Products

NetWorker
Article Properties
Article Number: 000212108
Article Type: Solution
Last Modified: 23 May 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.