DPC: DD SSO bağlantısı, bağlantı veya soket zaman aşımı ile başarısız oluyor

Summary: Bu makalede, SSO kaydı için DD ile Data Protection Central (DPC) arasındaki bağlantı sorunlarının giderilmesi ele alınmaktadır.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Data Protection Central'ı (DPC) Data Domain deki (DD) Çoklu Oturum Açma (SSO) kaydedilirken bağlantı veya soket zaman aşımı hataları oluyor.

Bunlar genellikle DPC ve DD sunucuları arasındaki ağ bağlantısı sorunlarıdır.

Cause

Bu, çeşitli ağ bağlantısı sorunlarından kaynaklanabilir.

Resolution

DPC ve DD arasındaki temel ağ bağlantısını kontrol edin:

Aşağıdaki komutu kullanarak DPC'den DD'ye giden 3009 numaralı bağlantı noktasının etkinleştirilip etkinleştirilmediğini kontrol edin:

  • SSH'i yönetici olarak kullanarak DPC CLI da oturum açın ve su - köklendirmek için aşağıdaki komutu çalıştırın:
  • Değiştirmek <DD_FQDN_OR_IP> DD sunucusunun FQDN'si ile ve <SYSADMIN_PASSWORD> sysadmin parolası ile.
curl -k -X POST https://<DD_FQDN_OR_IP>:3009/rest/v1.0/auth -H "Content-Type: application/json"  -d '{"username":"sysadmin","password":"<SYSADMIN_PASSWORD>"}'

Bu bağlantı çalışıyorsa ve 3009 numaralı bağlantı noktasına ulaşılabiliyorsa aşağıdakine benzer bir çıktı alırsınız:

{"details": "success", "code": 0, "link": [{"rel": "related", "href": "/rest/v1.0/system"}]}

Döndürülen "ayrıntılar" dozu "başarılı" göstermezse, bu bir ağ bağlantısı sorunudur ve ağ gönderilerinin açılmasını gerektirir.  

Bağlantı noktası 443'ün DD'den DPC'ye giden yolda etkin olup olmadığını kontrol edin. Bunu yapmak için sysadmin kullanıcı olarak SSH aracılığıyla DD CLI'da oturum açın. Ardından SE moduna girin:

system show serialno                     #To get the serialno of the system, which will be used to enter SE mode
                                         #When prompting for security officer authorization, enter SO username&password.
                                         #When prompting for system password, enter system serialno.
NOT: SE komutları, DDOS 7.7.5.25, 7.10.1.15, 7.13.0.15, 6.2.1.110 ve üzeri sürümlerde kullanımdan kaldırılmıştır ve yalnızca Dell çalışanları tarafından erişilebilir.

Ardından, DD FQDN'yi> DPC sunucusunun FQDN'si ile değiştirerek < aşağıdaki komutu çalıştırın:

se telnet <DPC FQDN> 443

Bağlantı çalışırsa, " ile bir satır görürsünüzConnected to <DPC FQDN>" dedi.

Eğer elg.log El sıkışma hatalarının şifreleri kontrol etmek için aşağıdakileri çalıştırdığını gösterir.

openssl s_client -tls1_2 -connect <DD_HOSTNAME>:3009 -cipher ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-SHA256:AES256-GCM-SHA384:AES256-SHA256:AES128-SHA256:AES128-SHA:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-SHA384:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-SHA256 2>/dev/null >dd_communication.txt


Değiştirmek <DD_HOSTNAME> yukarıdaki komutta DD sunucusunun FQDN'si ile.

dd_communication.txt" dosyasını kontrol edin. Aşağıdaki çıktı gibi görünmelidir.

CONNECTED(00000003)
---
Certificate chain
 0 s:/C=US/ST=CA/OU=Host Certificate/O=Valued DataDomain customer/CN=<DD_HOSTNAME>
   i:/C=US/ST=CA/L=Santa Clara/O=Valued Datadomain Customer/OU=Root CA/CN=<DD_HOSTNAME>
 1 s:/C=US/ST=CA/L=Santa Clara/O=Valued Datadomain Customer/OU=Root CA/CN=<DD_HOSTNAME>
   i:/C=US/ST=CA/L=Santa Clara/O=Valued Datadomain Customer/OU=Root CA/CN=<DD_HOSTNAME>
---
Server certificate
-----BEGIN CERTIFICATE-----
MIIEUzCCAzugAwIBAgIBBzANBgkqhkiG9w0BAQsFADCBljELMAkGA1UEBhMCVVMx
CzAJBgNVBAgMAkNBMRQwEgYDVQQHDAtTYW50YSBDbGFyYTEjMCEGA1UECgwaVmFs
dWVkIERhdGFkb21haW4gQ3VzdG9tZXIxEDAOBgNVBAsMB1Jvb3QgQ0ExLTArBgNV
BAMMJGRzbS00NDAwLXJ0cC5kcGFkLmdzbGFicy5sYWIuZW1jLmNvbTAeFw0yMjAz
MTUwMjE4NDVaFw0yNTAzMTQwNjE4NDVaMIGJMQswCQYDVQQGEwJVUzELMAkGA1UE
CAwCQ0ExGTAXBgNVBAsMEEhvc3QgQ2VydGlmaWNhdGUxIzAhBgNVBAoMGlZhbHVl
ZCBEYXRhRG9tYWluIGN1c3RvbWVyMS0wKwYDVQQDDCRkc20tNDQwMC1ydHAuZHBh
ZC5nc2xhYnMubGFiLmVtYy5jb20wggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEK
AoIBAQDT0H4LNjMAZ4zkJBle/zT/z4iiXQP3OXuuu2+XcpVeombzKFBcVm6dn14W
4r22YCKoy9am/ekSbZFGbvsoy6uapVii95pL6heF1rgKwCHKzcyjWKLuj15JSLfM
+R8zsk3JZYU0bQm/0BNaJe34trCX3aDhezJQD0r+MW2hS4rh3ogNjsg4TgtGO/Oh
fEB1bK9Ey99ehBc4h89/7/IMeexn9gyh0kfF+J7FG8agRAJLX7bJM/8FoXJDNdXS
tM3EJLHAMh+WhKmgngi705n6Plcuvgkd9C2rD41V/PxN4YQxBR3C1MOOEUr7BUdb
ryl9QxsktA52S/rcmTPW3ylhG7chAgMBAAGjgbYwgbMwCQYDVR0TBAIwADAOBgNV
HQ8BAf8EBAMCBaAwHQYDVR0lBBYwFAYIKwYBBQUHAwEGCCsGAQUFBwMCMHcGA1Ud
EQRwMG6CJGRzbS00NDAwLXJ0cC5kcGFkLmdzbGFicy5sYWIuZW1jLmNvbYcECuuR
NYcECuuRNocECuuRN4cQJiAAAAFwFgECUFb//r9SaYcQJiAAAAFwFgECUFb//r/J
3IcQJiAAAAFwFgECUFb//r/3wzANBgkqhkiG9w0BAQsFAAOCAQEAgVE6r4GCeCpA
ndZS3+qg86dlq+IgB0Yvelk0S+TeViYPf90Iyk3vgyjAaAazO4dLr3JnfobAmgCd
fDzRhHOs18sfQLdZm6WyYvtzENSb39EDI2U+VkTgmv+SEyRYsfoNTEqAomwIkxZE
mAMEjFEoDM7qIMAmfiRaDsjBf+NlbHRQNPeeTYisdI562IJgIbkZJUyZVEwwBuHA
OboSWtuy58p2Udvrbl3UzqZU32p0ZZPW+i1qwVPsbli2jf2Gf+CJjp+mPG4u72HY
dqj3FyACzc77+xCrbJ4Q5/y2aXOXjI9GzPA/lAvDKiKDCsr/+0UKtEN87T6l/CyB
BHCj1F+oKw==
-----END CERTIFICATE-----
subject=/C=US/ST=CA/OU=Host Certificate/O=Valued DataDomain customer/CN=<DD_HOSTNAME>
issuer=/C=US/ST=CA/L=Santa Clara/O=Valued Datadomain Customer/OU=Root CA/CN=<DD_HOSTNAME>
---
No client certificate CA names sent
Client Certificate Types: RSA sign, DSA sign, ECDSA sign
Requested Signature Algorithms: RSA+SHA512:DSA+SHA512:ECDSA+SHA512:RSA+SHA384:DSA+SHA384:ECDSA+SHA384:RSA+SHA256:DSA+SHA256:ECDSA+SHA256:RSA+SHA224:DSA+SHA224:ECDSA+SHA224:RSA+SHA1:DSA+SHA1:ECDSA+SHA1
Shared Requested Signature Algorithms: RSA+SHA512:DSA+SHA512:ECDSA+SHA512:RSA+SHA384:DSA+SHA384:ECDSA+SHA384:RSA+SHA256:DSA+SHA256:ECDSA+SHA256:RSA+SHA224:DSA+SHA224:ECDSA+SHA224:RSA+SHA1:DSA+SHA1:ECDSA+SHA                               1
---
SSL handshake has read 2247 bytes and written 479 bytes
---
New, TLSv1/SSLv3, Cipher is AES256-GCM-SHA384
Server public key is 2048 bit
Secure Renegotiation IS supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
SSL-Session:
    Protocol  : TLSv1.2
    Cipher    : AES256-GCM-SHA384
    Session-ID:
    Session-ID-ctx:
    Master-Key: 60D098B90CD2B06A410F64A70B4FC6285D42C4FBBE568FEF37D56AD9B414E39D2EA408B8ED120B0BDF4DF21F347E0211
    Key-Arg   : None
    PSK identity: None
    PSK identity hint: None
    SRP username: None
    Start Time: 1689168122
    Timeout   : 7200 (sec)
    Verify return code: 19 (self signed certificate in certificate chain)
---


"Paylaşılan İstenen İmza Algoritmaları" satırı boşsa, bu bir şifreleme sorunudur ve bunun çalışması için DPC'nin kullandığı şifreleri eklemek için DD ekibiyle birlikte çalışmamız gerekir.

SMS'i kontrol edin.Altındaki bilgi günlükleri /ddr/var/log/debug DD üzerindeki dizininde yer alır.


Eğer sms.info günlüğünde "SSO uç noktaları alınamadı" ifadesi görüntüleniyor. Data Domain, Data Protection Central ile Çoklu Oturum Açma Bağlantısını Reddediyor, bu sorunun çözümü için sorunun Data Domain'den Kontrol Edilmesi Gerekiyor


Daha fazla soru için Dell destek birimiyle iletişime geçin.

Affected Products

Data Protection Central

Products

Data Domain
Article Properties
Article Number: 000215743
Article Type: Solution
Last Modified: 31 Mar 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.