ЦОД: Не вдається з'єднати DD SSO з тайм-аутом підключення або розетки

Summary: У цій статті розглядаються проблеми з підключенням між DD і Data Protection Central (DPC) для реєстрації єдиного входу.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Під час реєстрації Data Protection Central (DPC) to Data Domain (DD) Single Sign On (SSO) виникають помилки часу очікування підключення або сокета.

Зазвичай це проблеми з мережевим з'єднанням між серверами DPC і DD.

Cause

Це може бути викликано різними проблемами з підключенням до мережі.

Resolution

Перевірте основне мережеве з'єднання між DPC і DD:

Перевірте, чи включений порт 3009 вихід з DPC в DD за допомогою наступної команди:

  • Увійдіть у DPC CLI, використовуючи SSH як адміністратор і su - щоб отримати root, то виконайте наступну команду:
  • Замінити <DD_FQDN_OR_IP> з FQDN сервера DD та <SYSADMIN_PASSWORD> з паролем сисадміна.
curl -k -X POST https://<DD_FQDN_OR_IP>:3009/rest/v1.0/auth -H "Content-Type: application/json"  -d '{"username":"sysadmin","password":"<SYSADMIN_PASSWORD>"}'

Якщо це з'єднання працює і порт 3009 доступний, ви отримуєте вихід, подібний до наступного:

{"details": "success", "code": 0, "link": [{"rel": "related", "href": "/rest/v1.0/system"}]}

Якщо повернута доза «деталей» не показує «успішно», то це проблема з мережевим з'єднанням, і вона вимагає відкриття мережевих повідомлень.  

Перевірте, чи включений порт 443 вихід з DD в DPC. Для цього авторизуйтесь у DD CLI за допомогою SSH як сисадміна користувача. Потім увійдіть у режим SE:

system show serialno                     #To get the serialno of the system, which will be used to enter SE mode
                                         #When prompting for security officer authorization, enter SO username&password.
                                         #When prompting for system password, enter system serialno.
ПРИМІТКА. Команди SE застаріли у версіях DDOS 7.7.5.25, 7.10.1.15, 7.13.0.15, 6.2.1.110 і вище і доступні лише співробітникам Dell.

Потім виконайте наступну команду заміни <DD FQDN> на FQDN сервера DPC:

se telnet <DPC FQDN> 443

Якщо з'єднання працює, ви бачите рядок з «Connected to <DPC FQDN>».

Якщо elg.log показує, що помилки рукостискання запускають наступне, щоб перевірити шифри.

openssl s_client -tls1_2 -connect <DD_HOSTNAME>:3009 -cipher ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-SHA256:AES256-GCM-SHA384:AES256-SHA256:AES128-SHA256:AES128-SHA:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-SHA384:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-SHA256 2>/dev/null >dd_communication.txt


Замінити <DD_HOSTNAME> з FQDN сервера DD у вищенаведеній команді.

Відзначте файл "dd_communication.txt", він повинен виглядати наступним виводом.

CONNECTED(00000003)
---
Certificate chain
 0 s:/C=US/ST=CA/OU=Host Certificate/O=Valued DataDomain customer/CN=<DD_HOSTNAME>
   i:/C=US/ST=CA/L=Santa Clara/O=Valued Datadomain Customer/OU=Root CA/CN=<DD_HOSTNAME>
 1 s:/C=US/ST=CA/L=Santa Clara/O=Valued Datadomain Customer/OU=Root CA/CN=<DD_HOSTNAME>
   i:/C=US/ST=CA/L=Santa Clara/O=Valued Datadomain Customer/OU=Root CA/CN=<DD_HOSTNAME>
---
Server certificate
-----BEGIN CERTIFICATE-----
MIIEUzCCAzugAwIBAgIBBzANBgkqhkiG9w0BAQsFADCBljELMAkGA1UEBhMCVVMx
CzAJBgNVBAgMAkNBMRQwEgYDVQQHDAtTYW50YSBDbGFyYTEjMCEGA1UECgwaVmFs
dWVkIERhdGFkb21haW4gQ3VzdG9tZXIxEDAOBgNVBAsMB1Jvb3QgQ0ExLTArBgNV
BAMMJGRzbS00NDAwLXJ0cC5kcGFkLmdzbGFicy5sYWIuZW1jLmNvbTAeFw0yMjAz
MTUwMjE4NDVaFw0yNTAzMTQwNjE4NDVaMIGJMQswCQYDVQQGEwJVUzELMAkGA1UE
CAwCQ0ExGTAXBgNVBAsMEEhvc3QgQ2VydGlmaWNhdGUxIzAhBgNVBAoMGlZhbHVl
ZCBEYXRhRG9tYWluIGN1c3RvbWVyMS0wKwYDVQQDDCRkc20tNDQwMC1ydHAuZHBh
ZC5nc2xhYnMubGFiLmVtYy5jb20wggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEK
AoIBAQDT0H4LNjMAZ4zkJBle/zT/z4iiXQP3OXuuu2+XcpVeombzKFBcVm6dn14W
4r22YCKoy9am/ekSbZFGbvsoy6uapVii95pL6heF1rgKwCHKzcyjWKLuj15JSLfM
+R8zsk3JZYU0bQm/0BNaJe34trCX3aDhezJQD0r+MW2hS4rh3ogNjsg4TgtGO/Oh
fEB1bK9Ey99ehBc4h89/7/IMeexn9gyh0kfF+J7FG8agRAJLX7bJM/8FoXJDNdXS
tM3EJLHAMh+WhKmgngi705n6Plcuvgkd9C2rD41V/PxN4YQxBR3C1MOOEUr7BUdb
ryl9QxsktA52S/rcmTPW3ylhG7chAgMBAAGjgbYwgbMwCQYDVR0TBAIwADAOBgNV
HQ8BAf8EBAMCBaAwHQYDVR0lBBYwFAYIKwYBBQUHAwEGCCsGAQUFBwMCMHcGA1Ud
EQRwMG6CJGRzbS00NDAwLXJ0cC5kcGFkLmdzbGFicy5sYWIuZW1jLmNvbYcECuuR
NYcECuuRNocECuuRN4cQJiAAAAFwFgECUFb//r9SaYcQJiAAAAFwFgECUFb//r/J
3IcQJiAAAAFwFgECUFb//r/3wzANBgkqhkiG9w0BAQsFAAOCAQEAgVE6r4GCeCpA
ndZS3+qg86dlq+IgB0Yvelk0S+TeViYPf90Iyk3vgyjAaAazO4dLr3JnfobAmgCd
fDzRhHOs18sfQLdZm6WyYvtzENSb39EDI2U+VkTgmv+SEyRYsfoNTEqAomwIkxZE
mAMEjFEoDM7qIMAmfiRaDsjBf+NlbHRQNPeeTYisdI562IJgIbkZJUyZVEwwBuHA
OboSWtuy58p2Udvrbl3UzqZU32p0ZZPW+i1qwVPsbli2jf2Gf+CJjp+mPG4u72HY
dqj3FyACzc77+xCrbJ4Q5/y2aXOXjI9GzPA/lAvDKiKDCsr/+0UKtEN87T6l/CyB
BHCj1F+oKw==
-----END CERTIFICATE-----
subject=/C=US/ST=CA/OU=Host Certificate/O=Valued DataDomain customer/CN=<DD_HOSTNAME>
issuer=/C=US/ST=CA/L=Santa Clara/O=Valued Datadomain Customer/OU=Root CA/CN=<DD_HOSTNAME>
---
No client certificate CA names sent
Client Certificate Types: RSA sign, DSA sign, ECDSA sign
Requested Signature Algorithms: RSA+SHA512:DSA+SHA512:ECDSA+SHA512:RSA+SHA384:DSA+SHA384:ECDSA+SHA384:RSA+SHA256:DSA+SHA256:ECDSA+SHA256:RSA+SHA224:DSA+SHA224:ECDSA+SHA224:RSA+SHA1:DSA+SHA1:ECDSA+SHA1
Shared Requested Signature Algorithms: RSA+SHA512:DSA+SHA512:ECDSA+SHA512:RSA+SHA384:DSA+SHA384:ECDSA+SHA384:RSA+SHA256:DSA+SHA256:ECDSA+SHA256:RSA+SHA224:DSA+SHA224:ECDSA+SHA224:RSA+SHA1:DSA+SHA1:ECDSA+SHA                               1
---
SSL handshake has read 2247 bytes and written 479 bytes
---
New, TLSv1/SSLv3, Cipher is AES256-GCM-SHA384
Server public key is 2048 bit
Secure Renegotiation IS supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
SSL-Session:
    Protocol  : TLSv1.2
    Cipher    : AES256-GCM-SHA384
    Session-ID:
    Session-ID-ctx:
    Master-Key: 60D098B90CD2B06A410F64A70B4FC6285D42C4FBBE568FEF37D56AD9B414E39D2EA408B8ED120B0BDF4DF21F347E0211
    Key-Arg   : None
    PSK identity: None
    PSK identity hint: None
    SRP username: None
    Start Time: 1689168122
    Timeout   : 7200 (sec)
    Verify return code: 19 (self signed certificate in certificate chain)
---


Якщо рядок "Shared Requested Signature Algorithms" порожній, то це проблема з шифром, і ми повинні звернутися до команди DD, щоб додати шифрувальники, які DPC використовує для цього, щоб це працювало.

Перевірте смс.Інформаційні журнали під /ddr/var/log/debug довідник на ДД.


Якщо смс.У інформаційному журналі відображається повідомлення "Не вдалося отримати кінцеві точки єдиного входу" за посиланням Домен даних відмовляється підключатися до Центру захисту даних, проблему потрібно перевірити в Data Domain для вирішення цієї проблеми. 


З додатковими запитаннями звертайтеся до служби підтримки Dell.

Affected Products

Data Protection Central

Products

Data Domain
Article Properties
Article Number: 000215743
Article Type: Solution
Last Modified: 31 Mar 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.