Comment déterminer les connexions client NFS sur PowerScale/Isilon
Summary: Requête NFS Existe-t-il un moyen de déterminer quels clients accèdent aux points de montage nfs sur chaque nœud d’un cluster? Ou existe-t-il de meilleures commandes ou méthodes pour obtenir les détails de montage du client nfs pour chaque nœud d’un cluster Isilon? ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
showmount -a peut répertorier tous les points de montage sous la forme:host:dirpath
En ce qui concerne l’utilisation de la commande « showmount -a », le support recommande de ne pas l’utiliser, car il ne s’agit pas d’un moyen fiable de surveiller les connexions.
1) Il fournit uniquement des informations spécifiques à partir du nœud spécifique il y a 10 minutes, de sorte qu’il n’est jamais à jour.
2) Si le montage présente un problème lié au client qui se connecte, même s’il fonctionne, il ne s’affiche même pas dans showmount.
3) Showmount n’affiche AUCUNE connexion NFSv4, uniquement v3.
Cause
Il n’existe aucune commande ou autre moyen d’accéder aux points de montage nfs sur chaque nœud d’un cluster. Il existe des zones d’accès et de nombreuses adresses IP sur les nœuds Isilon.
Resolution
Pour vérifier les statistiques actuelles Cette commande affiche le nombre de tous les clients connectés
et actifs
isi statistics query current --nodes=all --stats=node.clientstats.connected.nfs,node.clientstats.active.nfs,node.clientstats.active.nfs
Cette commande affiche également les clients NFS, mais il s’agit des clients actifs et n’affiche pas tous les clients NFS, y compris les clients inactifs, mais les clients montés NFS.
# isi statistics client --nodes=all --protocols=nfs3
Affected Products
PowerScale OneFSArticle Properties
Article Number: 000217710
Article Type: Solution
Last Modified: 22 Sept 2023
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.