PowerProtect: VM backup fails with Protected entity disk read error

Summary: PowerProtect Data Manager-VM backup failed with Protected entity disk read error.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

From the job log, we could see below key error:
BackupVmSessions-bdc746da-d21b-494c-a561-9f1fc2bcb122.log:   2024-03-21T17:15:39.743Z ERROR:  [9e1eb0ca37063d14;a102d2829478e32c] SDM Data Mover: SDM Full Sync: The vCenter task for 'SDM Snapshot Sync fullSync' completed with state 'error'.  TSDM Error Code: <ObjectReadError>, TSDM Error Message: <Protected entity disk read error. Error message: The requested system was too busy to execute the operation.>.

Cause

The VMware datastore where this Virtual Machine is located has a disk issue.

Resolution

Solution:
The customer may engage VMware support to confirm the issue and then engage the storage vendor to fix the disk issue.
From the VMware ESXI log, we an error like the one below:
 
LWD: Failed to read extent range [40696,40699], offset range [10668212224, 1048576], from disk B714DCE760 (capacity 53687091200), readTxn 10010. Error: 22: IO error

Workaround:
The customer could perform a storage migration for this affected VM.
If migration could be successful, then the backup would be working afterwards.
If migration also failed, then engage VMware support.

Affected Products

PowerProtect Data Manager, PowerProtect Software
Article Properties
Article Number: 000223734
Article Type: Solution
Last Modified: 14 May 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.