NVP vProxy: Il backup della VM non riesce a causa dell'errore VMware View "Unable to fetch data from vCenter"

Summary: I backup delle VM non riescono a causa di un problema di connessione con vCenter Server e questo articolo spiega la risoluzione.

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Symptoms

I backup di vCenter hanno esito negativo a causa di problemi di connessione con vCenter.

  • Viene visualizzato un errore in NMC simile a quello della KB: NVP-vProxy: View update fails, error "Unable to fetch data from vCenter: È stato osservato un EOF che viola il protocollo".
  • Errore NetWorker VMware View ricevuto:
    Unable to fetch data from vCenter: EOF was observed that violates the protocol.  The client probably provided invalid authentication information.
  • Il problema di connessione con vCenter genera errori SSL. Errore SSL nel file /opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-vddk.log di vProxy.
    VDDK INFO 2024-10-07T21:01:42.616+05:30 error -[04510] [Originator@6876 sub=IO] HandshakeCb; <SSL(<io_obj p:0x00007f2694008bc8, h:68, <TCP 'xxx.xxx.xxx.xxx : 60194'>, <TCP 'xxx.xxx.xxx.xxx : 443'>>)>; error: N7Vmacore3Ssl12SSLExceptionE(SSL Exception: error:140000DB:SSL routines:SSL routines:short read: The connection was closed by the remote end during handshake.)
    VDDK INFO 2024-10-07T21:01:42.749+05:30 error -[10320] [Originator@6876 sub=transport] Cannot connect to Server: SSL Exception: error:140000DB:SSL routines:SSL routines:short read: The connection was closed by the remote end during handshake..
    2024-10-07T15:31:42Z NOTICE: VDDK INFO 2024-10-07T21:01:42.791+05:30 warning -[10320] [Originator@6876 sub=transport] Fail to fetch ddb with double encoding, error(Cannot connect to server)
  • Il file /var/log/vmware/envoy/envoy.log di vCenter Server contiene:
    2024-10-09T22:32:56.814Z warning envoy[3248] [Originator@6876 sub=filter] [Tags: "ConnectionId":"737396"] remote https connections exceed max allowed: 2048
    2024-10-09T22:32:56.814Z warning envoy[3248] [Originator@6876 sub=filter] [Tags: "ConnectionId":"737396"] closing connection TCP<xxx.xxx.xxx.xxx:55718, xxx.xxx.xxx.xxx:443>

 

Cause

La root cause del problema è un problema di connessione tra vCenter Server e il server NetWorker, che determina un errore nei backup di vCenter. Il messaggio di errore di VMware View "EOF was observed that violates the protocol" indica un problema di connessione con vCenter.

Il file vbackupd-vddk.log dal server vProxy mostra un errore SSL con il messaggio:

"SSL Exception: error:140000DB:SSL routines:SSL routines:short read: The connection was closed by the remote end during handshake."

Il registro VMware Envoy mostra lo stesso errore, indicando un problema di esaurimento della connessione.

"remote https connections exceed max allowed: 2048" suggests that the vCenter server is exceeding the maximum allowed connections to the vProxy server.

Messaggio di chiusura della connessione: "closing connection TCP<xxx.xxx.xxx.xxx:55718, xxx.xxx.xxx.xxx:443>" indica che il server vProxy sta chiudendo la connessione a causa di un numero eccessivo di connessioni.

 

Resolution

Per impostazione predefinita, NetWorker eseguirà l'inventario di un vCenter ogni 15 minuti. Il processo di inventario di vCenter si verificherà anche ogni volta che un utente si connette al server NetWorker dalla NetWorker Management Console e ogni volta che viene avviata una policy di protezione VMware. L'intervallo di inventario "nsrvim" predefinito può essere aumentato fino a 60 minuti; vedere: NVP vProxy: Il processo nsrvim di NetWorker viene eseguito ogni 15 minuti, causando un carico di lavoro elevato su vCenter Server e una potenziale non disponibilità di VPXD

Se il problema persiste anche dopo aver aumentato la NSRVIM_TIME_INTERVAL a 60 minuti, effettuare le seguenti operazioni:

NOTA: Questo problema influisce su NetWorker VMware Protection; tuttavia, si verifica sul vCenter Server. Per risolvere il problema, contattare il team VMware o il supporto VMware per risolvere il problema di connessione tra i server vCenter e NetWorker.

La risoluzione del problema di errore di backup di vCenter consiste nel risolvere l'errore di esaurimento della connessione SSL. Attenersi alla procedura descritta di seguito per risolvere il problema.

  1. Seguire l'articolo della KB 344920 di VMware Questo link ipertestuale indirizza a un sito web esterno a Dell Technologies.
  2. Contattare il supporto VMware: Se l'articolo KB precedente non risolve il problema, contattare il supporto VMware per ulteriore assistenza.
ATTENZIONE: La disabilitazione della verifica SSL potrebbe compromettere la sicurezza dell'ambiente. Si consiglia di disabilitare la verifica SSL solo come ultima risorsa e solo dopo aver consultato il supporto VMware.

Dopo aver implementato i passaggi precedenti, verificare che il problema sia stato risolto controllando la presenza di errori relativi a SSL nei registri di vCenter Server e vProxy. Se il problema persiste, contattare il supporto VMware per ulteriore assistenza.

 

Additional Information

Verificare che il server NetWorker sia in grado di connettersi alla porta HTTPS di vCenter (443) tramite SSL:

openssl s_client -connect VCENTER_ADDRESS:443
NOTA: openssl è un'utilità di terze parti. In genere è incluso per impostazione predefinita nei sistemi operativi Linux; tuttavia, in genere non è incluso per impostazione predefinita nei sistemi operativi Windows. Ciò richiede l'installazione di openssl.

NVP vProxy: risoluzione dei problemi di connettività di rete per le operazioni di backup e ripristino

 

Affected Products

NetWorker
Article Properties
Article Number: 000236865
Article Type: Solution
Last Modified: 23 Jan 2025
Version:  3
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