NVP vProxy: VMware View 오류 "vCenter에서 데이터를 가져올 수 없음"으로 인해 VM 백업이 실패함

Summary: vCenter Server와의 연결 문제로 인해 VM 백업이 실패합니다. 이 문서에서는 해결 방법에 대해 설명합니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

vCenter 연결 문제로 인해 vCenter 백업이 실패합니다.

  • NMC에서 KB와 유사한 오류 수신: NVP-vProxy: 보기 업데이트 실패, 오류 "vCenter에서 데이터를 가져올 수 없음: 프로토콜을 위반하는 EOF가 관찰되었습니다."
  • NetWorker VMware View 오류 수신:
    Unable to fetch data from vCenter: EOF was observed that violates the protocol.  The client probably provided invalid authentication information.
  • vCenter와의 연결 문제로 인해 SSL 오류가 발생합니다. vProxy /opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-vddk.log 파일에 SSL 오류가 있습니다.
    VDDK INFO 2024-10-07T21:01:42.616+05:30 error -[04510] [Originator@6876 sub=IO] HandshakeCb; <SSL(<io_obj p:0x00007f2694008bc8, h:68, <TCP 'xxx.xxx.xxx.xxx : 60194'>, <TCP 'xxx.xxx.xxx.xxx : 443'>>)>; error: N7Vmacore3Ssl12SSLExceptionE(SSL Exception: error:140000DB:SSL routines:SSL routines:short read: The connection was closed by the remote end during handshake.)
    VDDK INFO 2024-10-07T21:01:42.749+05:30 error -[10320] [Originator@6876 sub=transport] Cannot connect to Server: SSL Exception: error:140000DB:SSL routines:SSL routines:short read: The connection was closed by the remote end during handshake..
    2024-10-07T15:31:42Z NOTICE: VDDK INFO 2024-10-07T21:01:42.791+05:30 warning -[10320] [Originator@6876 sub=transport] Fail to fetch ddb with double encoding, error(Cannot connect to server)
  • vCenter Server의 /var/log/vmware/envoy/envoy.log에는 다음이 포함됩니다.
    2024-10-09T22:32:56.814Z warning envoy[3248] [Originator@6876 sub=filter] [Tags: "ConnectionId":"737396"] remote https connections exceed max allowed: 2048
    2024-10-09T22:32:56.814Z warning envoy[3248] [Originator@6876 sub=filter] [Tags: "ConnectionId":"737396"] closing connection TCP<xxx.xxx.xxx.xxx:55718, xxx.xxx.xxx.xxx:443>

 

Cause

이 문제의 근본 원인은 vCenter Server와 NetWorker Server 간의 연결 문제로 인해 vCenter 백업이 실패하는 것입니다. VMware View 오류 메시지 "프로토콜을 위반하는 EOF가 관찰되었습니다"는 vCenter와의 연결 문제를 나타냅니다.

vProxy 서버의 vbackupd-vddk.log 파일에 다음과 같은 메시지와 함께 SSL 오류가 표시됩니다.

"SSL Exception: error:140000DB:SSL routines:SSL routines:short read: The connection was closed by the remote end during handshake."

VMware 엔보이 로그에 연결 소모 문제를 나타내는 동일한 오류가 표시됩니다.

"remote https connections exceed max allowed: 2048" suggests that the vCenter server is exceeding the maximum allowed connections to the vProxy server.

연결 닫기 메시지: "closing connection TCP<xxx.xxx.xxx.xxx:55718, xxx.xxx.xxx.xxx:443>"는 과도한 연결로 인해 vProxy 서버가 연결을 닫고 있음을 나타냅니다.

 

Resolution

기본적으로 NetWorker는 15분마다 vCenter의 인벤토리를 생성합니다. vCenter 인벤토리 프로세스는 사용자가 NetWorker Management Console에서 NetWorker Server에 연결할 때와 VMware 보호 정책이 시작될 때도 발생합니다. 기본 "nsrvim" 인벤토리 간격은 최대 60분까지 늘릴 수 있습니다. 다음을 참조하십시오. NVP vProxy: NetWorker nsrvim 프로세스가 15분마다 실행되어 vCenter Server의 워크로드가 높아지고 VPXD의 가용성 손실이 발생할 수 있음

NSRVIM_TIME_INTERVAL 60분으로 늘린 후에도 문제가 지속되면 다음을 수행하십시오.

참고: 이 문제는 NetWorker VMware 보호에 영향을 미칩니다. 그러나 vCenter Server에서 발생하고 있습니다. 이 문제를 해결하려면 VMware 팀 또는 VMware 지원에 문의하여 vCenter와 NetWorker Server 간의 연결 문제를 해결하십시오.

vCenter 백업 실패 문제에 대한 해결 방법은 SSL 연결 소모 오류를 해결하는 것입니다. 문제를 해결하려면 다음 단계를 따르십시오.

  1. VMware KB 344920 팔로우 이 하이퍼링크는 Dell Technologies 외부의 웹사이트로 연결됩니다.
  2. VMware 지원 문의: 위의 KB를 통해 문제를 해결할 수 없는 경우 VMware 지원팀에 문의하여 추가 지원을 받으십시오.
주의: SSL 확인을 비활성화하면 환경의 보안이 손상될 수 있습니다. 최후의 수단으로 SSL 확인을 비활성화하는 것은 VMware 지원팀과 상담한 후에만 수행하는 것이 좋습니다.

위의 단계를 구현한 후 vCenter Server 및 vProxy 로그에서 SSL 관련 오류를 확인하여 문제가 해결되었는지 확인합니다. 문제가 계속되면 VMware 지원팀에 문의하여 추가 지원을 받으십시오.

 

Additional Information

NetWorker Server가 SSL을 통해 vCenter HTTPS 포트(443)에 연결할 수 있는지 확인합니다.

openssl s_client -connect VCENTER_ADDRESS:443
참고 : openssl은 타사 유틸리티입니다. 일반적으로 Linux 운영 체제에 기본적으로 포함되어 있습니다. 그러나 일반적으로 Windows 운영 체제에는 기본적으로 포함되지 않습니다. 이를 위해서는 openssl을 설치해야 합니다.

NVP vProxy: 백업 및 복원 작업을 위한 네트워크 연결 문제 해결

 

Affected Products

NetWorker
Article Properties
Article Number: 000236865
Article Type: Solution
Last Modified: 23 Jan 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.