PowerFlex Manager: RKE2-oppgraderingen mislykkes gjentatte ganger på grunn av feilmeldingen "405 ikke tillatt"

Summary: PowerFlex Manager: RKE2-oppgraderingen mislykkes gjentatte ganger på grunn av feilmeldingen "405 ikke tillatt" under oppretting av nyttelasten for oppgraderingen Under oppgraderingen av PowerFlex Management Platform (PFMP) mislykkes prosessen gjentatte ganger, og gjentas når du oppretter nyttelastmappen for oppgraderingen i den delte HTTP-ressursen. Feilen oppstår med en HTTP 405 ikke tillatt-feil. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Påvirket versjon:

Powerflex Manager 4.x

Når en bruker utfører en RKE2-oppgradering som en del av PFMP-oppgraderingen, oppstår følgende symptomer:

  • Oppgraderingsprosessen laster kontinuerlig ned pakken, men mislykkes under opprettingsfasen for nyttelast.
  • Logger fra alcm pod viser feilen '405 ikke tillatt' mens du prøver å opprette oppgraderingsnyttelastmappen i http-delingen
    2024-11-30T06:37:50.452413347-06:00 stdout F 2024-11-30 12:37:50 [pool-2-thread-1] (UpgradePFMP.java:168) [INFO] Starting PFMP upgrade
    ..
    2024-11-30T06:49:06.712045703-06:00 stdout F 2024-11-30 12:49:06 [pool-2-thread-1] (UpgradePFMP.java:718) [DEBUG] PFMP Bundle download progress 100%
    ..
    2024-11-30T06:53:47.628162548-06:00 stdout F 2024-11-30 12:53:47 [pool-2-thread-1] (UpgradePFMP.java:1681) [INFO] Current RKE2 version: 1.25.3
    2024-11-30T06:53:47.629703367-06:00 stdout F 2024-11-30 12:53:47 [pool-2-thread-1] (UpgradePFMP.java:1688) [INFO] Available RKE2 version: 1.26.13
    ...
    024-11-30T06:54:02.071950984-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] Moving RKE2 artifacts to upgrade-artifacts folder . . .
    2024-11-30T06:54:02.344803044-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] /opt/Dell/ASM/temp/upgrade853246658060560317/Upgrade/prepare-upgrade.sh: line 264: kubectl: command not found
    2024-11-30T06:54:02.368496491-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] Creating upgrade payload folder in http-share . . .<html>
    2024-11-30T06:54:02.368527723-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] <head><title>405 Not Allowed</title></head>
    2024-11-30T06:54:02.368533448-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] <body>
    2024-11-30T06:54:02.368548798-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] <center><h1>405 Not Allowed</h1></center>
    2024-11-30T06:54:02.368553418-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] <hr><center>nginx/1.21.5</center>
    2024-11-30T06:54:02.368565659-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] </body>
    2024-11-30T06:54:02.36859845-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] </html>
    2024-11-30T06:54:02.369264313-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG]  done.

 

Cause

PFMP er avhengig av httpshare-ingress-ingress-upload for RKE2-oppgraderinger på nodenivå, noe som muliggjør opplasting av nodeoppgraderingsmoduler.
Et "CMO_Patch.zip"-skript fra nettstedet for kundestøtte hos Dell begrenset opplastingsmulighetene for delt http-ressurs for å redusere et sikkerhetsproblem, noe som førte til feil i oppgraderingen.

 

Resolution

Omgåelse av problemet

  • Kontroller at httpshare-ingress-upload-ingress ikke finnes

    kubectl get ingress -A | egrep httpshare-ingress
  • Overfør YAML-filen:
    Kopier "httpshare-ingress-upload.zip"-filen som er vedlagt denne KB-en, til en av MVM-nodene, og pakk den ut.

  • Bruk Ingress Fix:
    Logg på MVM-noden, gå til katalogen der YAML-filen er lagret, og bruk innstillingene:

    kubectl apply -f httpshare-ingress-upload.yaml
  • Bekreft oppretting av inngang:
    Kontroller at httpshare-ingress-upload-inngangen er opprettet. Det kan ta 15–30 sekunder før IP-adressene fylles ut. Sjekk med:

    kubectl get ingress -n powerflex | egrep -i httpshare
  • Start alcm-kapselen på nytt

    kubectl delete pod $(kubectl get pods -n powerflex | egrep alcm | awk '{print $1}') -n powerflex
  • Kontroller ACLM pod-loggene for å se om oppgraderingen kjører. Hvis ikke, kan du prøve PFMP-oppgraderingen på nytt:
    Start oppgraderingsprosessen på nytt. Problemet skal nå være løst.

 

Handlinger etter oppgradering:

Når PFMP-oppgraderingen er fullført, følger du fremgangsmåten nedenfor basert på PFMP-versjonen:

  • For systemer som kjører PFMP-versjoner som er eldre enn 4.6.1:

    • Bruk CVE-utbedringsverktøyet (CMO_Patch.zip) på nytt for å sikre kontinuerlig overholdelse av sikkerheten. Se KB-utbedring for Powerflex Manager CVE-2024-37143 (Dell Support-konto er nødvendig for å vise denne artikkelen)
      Merk: For alle fremtidige oppgraderinger må løsningen som er nevnt ovenfor, brukes på nytt, med mindre systemet oppgraderes til versjon 4.6.1 eller nyere.
  • For systemer som kjører PFMP versjon 4.6.1 eller nyere:

    • Ingen ekstra handling er nødvendig etter oppgraderingen.

 

Løst i versjon: PowerFlex Manager 4.6.1

Additional Information

Viktig

Hvis PFMP-installasjonen (Powerflex Manager) tidligere ble utført som rotbruker, må du kontrollere at eierskapet til følgende kataloger oppdateres på riktig måte før du fortsetter med PFMP-oppgraderingen. Hvis du vil ha mer informasjon, kan du se PowerFlex Management Platform – PFXM-oppgradering mislykkes på oppgave Fjern landingsdir for artefaktdestinasjon

Products

PowerFlex rack, PowerFlex Appliance, PowerFlex custom node, PowerFlex Software
Article Properties
Article Number: 000261179
Article Type: Solution
Last Modified: 22 Jan 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.