PowerFlex Gateway non disponibile dopo le modifiche al certificato HTTPS
Summary: Descrizione del problema: Dopo aver modificato il certificato SSL da autofirmato a personalizzato utilizzato dal gateway PowerFlex per l'accesso al browser, la pagina web non è più accessibile. ...
Symptoms
Sintomi
- Utilizzando l'IP o il nome DNS per gli stati del gateway, il sito non può essere raggiunto.
- Il servizio è in esecuzione.
# systemctl status scaleio-gateway
● scaleio-gateway.service - EMC ScaleIO Gateway service
Loaded: loaded (/etc/systemd/system/scaleio-gateway.service; enabled; vendor preset: disabled)
Active: active (running) since Mon 2023-11-06 13:21:11 EST; 3min 44s ago
Process: 23621 ExecStart=/opt/emc/scaleio/gateway/bin/startup.sh > /dev/null 2> /dev/null (code=exited, status=0/SUCCESS)
Main PID: 23635 (java)
CGroup: /system.slice/scaleio-gateway.service
└─23635 /usr/bin/java -Djava.util.logging.config.file=/opt/emc/scaleio/gateway/conf/logging.properties -Djava.util.logging.manager=org.apache.jul...
Nov 06 13:21:11 rhel-79 systemd[1]: Starting EMC ScaleIO Gateway service...
Nov 06 13:21:11 rhel-79 startup.sh[23621]: Tomcat started.
Nov 06 13:21:11 rhel-79 systemd[1]: Started EMC ScaleIO Gateway service.
- I file di log di Catalina mostrano che non è possibile aprire il keystore:
06-Nov-2023 11:59:04.189 SEVERE [main] org.apache.catalina.core.StandardService.initInternal Failed to initialize connector [Connector[HTTP/1.1-443]]
org.apache.catalina.LifecycleException: Protocol handler initialization failed
at org.apache.catalina.connector.Connector.initInternal(Connector.java:1075)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
Caused by: java.lang.IllegalArgumentException: Keystore was tampered with, or password was incorrect
Impatto
L'interfaccia utente del gateway non è disponibile.
Cause
Root cause:
In questo caso, il file /opt/emc/scaleio/gateway/conf/catalina.properties contiene due valori che vengono modificati quando si aggiunge un certificato personalizzato al gateway:keystore.file = <keystore location>keystore.password = <password>
Alla fine della riga la password per l'archivio chiavi aveva uno spazio aggiuntivo.
Resolution
Soluzione alternativa
Rimuovere gli spazi aggiuntivi alla fine della riga della password e riavviare il servizio gateway.
service scaleio-gateway restart
Verificare che l'archivio chiavi possa essere aperto come previsto con questo comando:
keytool -list -keystore <keystore location> -storepass <password>
Se si apre, significa che la password è corretta.
Versioni interessate
PowerFlex 3.x
Risolto nella versione
N/D - Non è un problema di PowerFlex