La passerelle PowerFlex n’est pas disponible après la modification du certificat HTTPS
Summary: Description du problème : Après avoir modifié le certificat SSL auto-signé en certificat personnalisé que la passerelle PowerFlex utilise pour accéder au navigateur, la page Web n’est plus accessible. ...
Symptoms
Symptômes
- L’utilisation de l’adresse IP ou du nom DNS pour la passerelle indique que le site n’est pas accessible.
- Le service fonctionne correctement.
# systemctl status scaleio-gateway
● scaleio-gateway.service - EMC ScaleIO Gateway service
Loaded: loaded (/etc/systemd/system/scaleio-gateway.service; enabled; vendor preset: disabled)
Active: active (running) since Mon 2023-11-06 13:21:11 EST; 3min 44s ago
Process: 23621 ExecStart=/opt/emc/scaleio/gateway/bin/startup.sh > /dev/null 2> /dev/null (code=exited, status=0/SUCCESS)
Main PID: 23635 (java)
CGroup: /system.slice/scaleio-gateway.service
└─23635 /usr/bin/java -Djava.util.logging.config.file=/opt/emc/scaleio/gateway/conf/logging.properties -Djava.util.logging.manager=org.apache.jul...
Nov 06 13:21:11 rhel-79 systemd[1]: Starting EMC ScaleIO Gateway service...
Nov 06 13:21:11 rhel-79 startup.sh[23621]: Tomcat started.
Nov 06 13:21:11 rhel-79 systemd[1]: Started EMC ScaleIO Gateway service.
- Les fichiers journaux catalina indiquent que le magasin de clés ne peut pas être ouvert :
06-Nov-2023 11:59:04.189 SEVERE [main] org.apache.catalina.core.StandardService.initInternal Failed to initialize connector [Connector[HTTP/1.1-443]]
org.apache.catalina.LifecycleException: Protocol handler initialization failed
at org.apache.catalina.connector.Connector.initInternal(Connector.java:1075)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
Caused by: java.lang.IllegalArgumentException: Keystore was tampered with, or password was incorrect
Impact
L’interface utilisateur de la passerelle n’est pas disponible.
Cause
Cause
Dans ce cas, le fichier /opt/emc/scaleio/gateway/conf/catalina.properties possède deux valeurs qui sont modifiées lors de l’ajout d’un certificat personnalisé à la passerelle :keystore.file = <keystore location>keystore.password = <password>
Le mot de passe du magasin de clés comportait un espace supplémentaire à la fin de la ligne.
Resolution
Solution
Supprimez les espaces blancs à la fin de la ligne de mot de passe et redémarrez le service de passerelle.
service scaleio-gateway restart
Vérifiez que le magasin de clés peut être ouvert comme prévu à l’aide de cette commande :
keytool -list -keystore <keystore location> -storepass <password>
S’il s’ouvre, cela signifie que le mot de passe est correct.
Versions affectées
PowerFlex 3.x
Problème résolu dans la version
S/O : il ne s’agit pas d’un problème PowerFlex