PowerProtect: SQL 2022-sikkerhedskopier mislykkes med kan ikke logge ind på SQL Server-fejl
Summary: SQL 2022-sikkerhedskopier mislykkes på grund af fejlen 'Kan ikke logge ind på SQL Server'.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
SQL 2022-sikkerhedskopieringer mislykkes med en fejlmeddelelse, der angiver, at udbyderen ikke kan findes.
- Fejlmeddelelsen
"Provider cannot be found. It may not be properly installed"vist. - Fejlkoden 800a0e7a opstår.
- Fejlbeskrivelsen
"Unknown error 0x800A0E7A"vist. - Kilden til fejlen er angivet som ADODB. Forbindelse.
- Forbindelsesforsøget til SQL Server mislykkes.
Cause
Den grundlæggende årsag til problemet er PPDM's manglende evne til at oprette forbindelse til SQL Server ved hjælp af OLE DB-driverversion 19.x.x.x.
Fejlmeddelelsen nævner også en COM-fejl med kode 800a0e7a, hvilket indikerer et problem med ADODB. Forbindelse.
2025-03-18T14:41:51.779Z Forsøger at oprette forbindelse til SQL Server 'SQLVM\SQL2022' ved hjælp af OLEDB-provider:'MSOLEDBSQL'.
2025-03-18T14:41:51.779Z D:/views/ci/workspace/_appagent_appagent_release_19.18/nsr/db_apps/bsmsql/nsrsqlado.cpp(1595): Indtastning af adoOpenConnectionEx().
2025-03-18T14:41:51.967Z D:/views/ci/workspace/_appagent_appagent_release_19.18/nsr/db_apps/bsmsql/nsResolution
Følg disse trin for at løse problemet:
- Installer OLE DB-driver 18.7.4 eller
- Installer den oprindelige SQL-driver.
Article Properties
Article Number: 000300476
Article Type: Solution
Last Modified: 02 May 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.