PowerProtect: SQL 2022-back-ups mislukken met fout Kan niet inloggen bij SQL Server

Summary: SQL 2022-back-ups mislukken vanwege het bericht 'Kan niet aanmelden bij SQL Server'.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SQL 2022-back-ups mislukken met een foutmelding die aangeeft dat de provider niet kan worden gevonden.

  • De foutmelding "Provider cannot be found. It may not be properly installed" weergegeven.
  • De foutcode 800a0e7a wordt aangetroffen.
  • De beschrijving van de fout "Unknown error 0x800A0E7A" weergegeven.
  • De bron van de fout wordt vermeld als ADODB. Verbinding.
  • De verbindingspoging met SQL Server mislukt.

Cause

De hoofdoorzaak van het probleem is het onvermogen van de PPDM om verbinding te maken met SQL Server met behulp van de OLE DB driverversie 19.x.x.x.

    De foutmelding vermeldt ook een COM-fout met code 800a0e7a, wat wijst op een probleem met de ADODB. Verbinding.
    2025-03-18T14:41:51.779Z Poging om verbinding te maken met SQL Server 'SQLVM\SQL2022' met behulp van OLEDB-provider:'MSOLEDBSQL'.
    2025-03-18T14:41:51.779Z D:/views/ci/workspace/_appagent_appagent_release_19.18/nsr/db_apps/bsmsql/nsrsqlado.cpp(1595): Entering adoOpenConnectionEx().
    2025-03-18T14:41:51.967Z D:/views/ci/workspace/_appagent_appagent_release_19.18/nsr/db_apps/bsmsql/ns

    Resolution

    Volg deze stappen om het probleem te verhelpen:

    • Installeer OLE DB driver 18.7.4 of 
    • Installeer de native SQL-driver.
    Article Properties
    Article Number: 000300476
    Article Type: Solution
    Last Modified: 02 May 2025
    Version:  1
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.