NetWorker: Kopie zapasowe NMDA Oracle: Odmowa uwierzytelnienia (bazy danych 11Gb/s).

Summary: Kopie zapasowe NMDA Oracle nie uruchamiają poprawnie skryptów przed poleceniem względem baz danych Oracle 11g.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Kopia zapasowa Oracle kończy się niepowodzeniem wskutek błędu:

Thu Oct 17 14:57:37 2024
Thu Oct 17 14:57:37 2024
Executing command: /usr/bin/nsr_pre_testSIST.sh
Set the signal's handler.
Cannot su to "oracle" : Authentication is denied.
Cannot su to "oracle" : Authentication is denied.
The command executed successfully: /usr/bin/nsr_pre_testSIST.sh
Reset the signal's handler.
Pre-processing command succeeded.

Cause

Podczas tworzenia kopii zapasowych Oracle NMDA nsrdasv używa interfejsów API Oracle do łączenia się z bazą danych na potrzeby uwierzytelniania systemu operacyjnego.
Podczas tego procesu nsrdasv łączy się jako określony użytkownik oracle przy użyciu polecenia SYSBACKUP, a następnie SYSDBA (jeśli pierwsze nie powiedzie się).
Gdy nsrdasv zakończy łączenie się z bazą danych, powraca do UID 0 (root) i uruchamia skrypt przed poleceniem. 

Problem dotyczy bazy danych Oracle DB 11g, która nie ma roli SYSBACKUP; nsrdasv does nie przywraca identyfikatora uid/gid do katalogu root po nieudanej próbie wykonania kopii zapasowej SYSBACKUP.
Powoduje to, że nsrdasv zapisuje nieprawidłowy identyfikator uid/gid systemu operacyjnego (oracle) podczas próby roli SYSDBA; Podczas przywracania identyfikatora użytkownika powraca do nieprawidłowego identyfikatora uid/gid.

Resolution

Poprawka kodu rozwiązująca ten problem znajduje się w wersjach 19.12, 19.10.0.7 i 19.11.0.3.

Affected Products

NetWorker Module for Databases and Applications

Products

NetWorker Family, NetWorker Module
Article Properties
Article Number: 000312013
Article Type: Solution
Last Modified: 07 Aug 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.