Falha no upgrade do PowerFlex 3.x para 4.x; um backup do banco de dados falha devido a um problema com o ElasticSearch

Summary: Este artigo explica como resolver a falha de upgrade da versão 3.x para 4.x devido a uma falha de backup e a um problema com o ElasticSearch.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Falha no upgrade do PowerFlex 3.x para 4.x durante o procedimento de importação; um backup do banco de dados do PowerFlex 3.8.3 antigo é acionado e apresenta falha.

 

2025-05-21 15:10:06,299 INFO [backup-1,tid=252] (BackupApplianceCallable.java:216): Executing the script: /opt/Dell/scripts/backup-elasticsearch.py
2025-05-21 15:10:16,779 DEBUG [backup-1,tid=252] (ExecuteSystemCommands.java:103): Last login: Wed May 21 15:10:01 CEST 2025 on cron
2025-05-21 15:10:16,780 ERROR [backup-1,tid=252] (ExecuteSystemCommands.java:127): Non-zero return code running OS command /usr/bin/sudo /opt/Dell/scripts/backup-elasticsearch.py: 3
2025-05-21 15:10:16,781 ERROR [backup-1,tid=252] (ExecuteSystemCommands.java:128): Console output running OS command: Last login: Wed May 21 15:10:01 CEST 2025 on cron
2025-05-21 15:10:16,781 ERROR [backup-1,tid=252] (BackupApplianceCallable.java:225): Error executing the script /opt/Dell/scripts/backup-elasticsearch.py: rc=3
2025-05-21 15:10:16,781 ERROR [backup-1,tid=252] (BackupApplianceCallable.java:246): Unable to backup the database. com.dell.asm.i18n2.exception.AsmCheckedException: The appliance cannot be backed because of an unknown exception.
2025-05-21 15:10:16,785 INFO [backup-1,tid=252] (BackupApplianceCallable.java:73): Executing the script /opt/Dell/scripts/backup-clean.sh

 

Log do gerente do ASM
 

Line 16272: 2025-05-21 11:32:50,308 DEBUG [backup-1,tid=245] (ExecuteSystemCommands.java:103): rm: cannot remove ‘/var/es-backup/indices’: Directory not empty
Line 16276: 2025-05-21 11:32:50,315 ERROR [backup-1,tid=245] (ExecuteSystemCommands.java:128): Console output running OS command: rm: cannot remove ‘/var/es-backup/indices’: Directory not emptyCleanup of /var/es-backup failed with RC=1Last login: Wed May 21 11:32:35 CEST 2025
Line 18203: 2025-05-21 12:02:54,161 DEBUG [backup-1,tid=245] (ExecuteSystemCommands.java:103): rm: cannot remove ‘/var/es-backup/indices’: Directory not empty
Line 18207: 2025-05-21 12:02:54,165 ERROR [backup-1,tid=245] (ExecuteSystemCommands.java:128): Console output running OS command: rm: cannot remove ‘/var/es-backup/indices’: Directory not emptyCleanup of /var/es-backup failed with RC=1Last login: Wed May 21 12:02:37 CEST 2025

Cause

Um problema com os dados do ElasticSearch  

Resolution

Os comandos são executados na CLI do PowerFlex Manager usando a conta delladmin .

 

Etapa 1 = liberar espaço no banco de dados de pesquisa elástica (o tamanho máximo deve ser 5G)

   

  • curl 'localhost:9200/_cat/indices?v’

 

Se houver muitos índices de trap snmp, não há problema em excluir traps mais antigas se você estiver de acordo com isso:

 

  • curl -X DELETE localhost:9200/snmp-traps-YYYY.MM.DD (this deletes a specific date)

 

Ou você pode excluí-los todos com o comando abaixo:

 

  • curl -X DELETE 'http://localhost:9200/syslog* [localhost]'

 

Etapa 2 = remover logs de pesquisa elástica.

  • sudo systemctl status Elasticsearch
    sudo systemctl stop Elasticsearch
    
    cd /var/log/elasticsearch (note: Do not delete vxfm-es-cluster.log)
    rm -rf *log.gz*
    rm -rf *gc.log*
    rm -rf *showlog.log*
    
    Systemctl start Elasticsearch
    sudo systemctl status Elasticsearch


Etapa 3 = Excluir TODOS os dados no ElasticSearch: 

*Advertência: O cliente perderá todos os alertas históricos, as medições de desempenho dos recursos e os dados do syslog.

 

  • curl -XDELETE localhost:9200/_all

 

Verifique o status e interrompa o serviço rsyslog.

 

systemctl status rsyslog

systemctl stop rsyslog

 

Tente novamente e inicie o serviço syslog:

systemctl start rsyslog

 

 

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000323551
Article Type: Solution
Last Modified: 19 Jun 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.