Cyber Recovery: NetWorker DRが「Unable to set user privileges based on user token for SYSTEM...」というエラーで失敗します。

Summary: Cyber Recovery: NetWorker DRがエラー メッセージで失敗します。networker.server.vault上のSYSTEMのユーザー トークンに基づいてユーザー権限を設定できません。セキュリティ トークンの検証に失敗しました。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

ログの障害点は、 nsrdr コマンドがブートストラップ データをリカバリした後です。その後、RESTを使用してデバイスのアンマウントを試みます。自動化されたCyber Recovery DRを中断するエラーが発生します。

以下は、Cyber Recoveryホストの「apps.log」からの抽出です。
 
[2023-02-28 13:22:54.062] [INFO] [apps] [ddssh.go:718 CreateSSHClientConn()] : SSH connecting to 192.168.1.10:22 
[2023-02-28 13:22:54.179] [INFO] [apps] [ddssh.go:317 RunSSHCmd()] : Running: 192.168.1.10:22 nsrdr -d 192.168.1.20_vault_dev_0 -B 2432563240 -a -A
[2023-02-28 13:28:14.608] [INFO] [apps] [RecoverNetWorkerApp.go:1278 NWUnmountDevices()] : Umounting devices from the vault before running DR procedure...
[2023-02-28 13:28:14.609] [INFO] [apps] [restapi_client.go:261 CallRESTAPI()] : Methods is :GET URL is:https://192.168.1.10:9090/nwrestapi/v2/datazone/devices
[2023-02-28 13:28:19.522] [INFO] [apps] [appsUtils.go:109 HandleNWResponse()] : REST status code :500
[2023-02-28 13:28:19.523] [ERROR] [apps] [appsUtils.go:123 HandleNWResponse()] : Error response is : {Message:Unable to set user privileges based on user token for SYSTEM on networker.server.vault: Failed to validate security token.
 Status:{Code:500 Class:Server Error Reason:Internal Server Error}}

ヴォールトNetWorkerサーバーのレンダリングされたdaemon.logから抽出します。
 
28/02/2023 13:28:10  nsrd NSR info Disaster Recovery Notice: Bootstrap recovery from the backup 2432563240 is completed with the status Succeeded  
28/02/2023 13:28:15  nsrd AUTHC critical Unable to set user privileges based on user token for SYSTEM on networker.server.vault: Failed to validate security token. 

Cyber Recovery Managerのエラー。

Cyber Recovery Managerのエラー
 
 
 

Cause

ヴォールトNetWorkerサーバー上のSYSTEMトークンが無効です。デフォルトの状態(DRを実行する前)でNetWorkerサーバーのNMCにログインしても、エラーで失敗します。

エラーメッセージ
 
 

Resolution

  1. 失敗したNetWorkerアプリケーション リカバリをクリーンアップして、ヴォールトNetWorkerサーバーがデフォルトの状態になるようにします(まだ実行していない場合)。
  2. ヴォールトでNetWorkerをアンインストールします。
  3. 「...」の名前を変更します。\EMC NetWorker\nsr フォルダーを「...\EMC NetWorker\old.nsr」と「...\EMC NetWorker\Management フォルダーを「...\EMC NetWorker\old。管理
  4. 同じ場所にNetWorkerを再インストールし、同じバージョンを使用し、以前と同じ認証情報を使用します。
  5. NetWorkerが動作していることを確認します。
  6. Cyber RecoveryでNetWorker資産を削除して再作成します。
  7. DRを再度実行します。

Affected Products

PowerProtect Cyber Recovery, NetWorker

Products

Cyber Recovery Series
Article Properties
Article Number: 000210780
Article Type: Solution
Last Modified: 19 Sept 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.