Dell Unity: Unisphere UI fails to log in as LDAP User when TLS1.0 is disabled with message "The logged in user is not authorized to access Unisphere" (Dell Correctable)
Summary: Unisphere UI fails to log in as LDAP User when TLS1.0 is disabled with message "The logged in user is not authorized to access Unisphere."
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Unity OE upgraded to version 4.3.
LDAP Server protocol is changed to block TLSv1.
Issue:
LDAP Users are unable to log in to Unisphere UI (Not a configuration issue as the users were working before).
The same user can successfully run commands using uemcli. Only using Unisphere UI, does this user fail to log in.
Example:
LDAP Server protocol is changed to block TLSv1.
Issue:
LDAP Users are unable to log in to Unisphere UI (Not a configuration issue as the users were working before).
Figure 1: LDAP User Unauthorized User Error Message
The same user can successfully run commands using uemcli. Only using Unisphere UI, does this user fail to log in.
Example:
uemcli -d array_name_or_ip -u LDAP.com/user100 -securepassword /stor/prov/luns/lun show
Cause
LDAP Server only has TLS1.2 enabled. TLS1.0 and TLS1.1 are disabled.
Support for TLS1.2 is only supported with Unity versions 4.3 and later. If the Unity OE is 4.2.x or earlier, this is normal behavior.
A fresh install or re-Initialization of 4.3 does not have this issue.
Support for TLS1.2 is only supported with Unity versions 4.3 and later. If the Unity OE is 4.2.x or earlier, this is normal behavior.
NOTE: If Unity OE code is upgraded from 4.2.x or earlier, it fails to update one important file. This causes the Unisphere UI to still attempt to use TLSv1.0 (even if it is disabled or enabled in the Unity Security).
A fresh install or re-Initialization of 4.3 does not have this issue.
Resolution
If the Unity OE is 4.2.x or earlier, support for TLS1.2 is not available until Unity OE is upgraded to version 4.3.
If the Unity OE is 4.3.0.x, contact Dell Support and quote this KB for manually updating the required file (No impact to production).
If the Unity OE is 4.3.0.x, contact Dell Support and quote this KB for manually updating the required file (No impact to production).
Affected Products
Dell EMC Unity FamilyProducts
Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F
, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition
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Article Properties
Article Number: 000035540
Article Type: Solution
Last Modified: 27 Apr 2023
Version: 3
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