Dell EMC Unity: Some Microsoft Office files are being saved incorrectly (User Correctable)
Summary: In Dell EMC Unity code level 5.0 an issue was introduced, where edited files from Microsoft Excel and Photo Viewer are not saved correctly.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
After upgrading the Dell EMC Unity array to code level 5.0, when editing existing Microsoft Office files, the changes are not saved on exit. Instead a .tmp file remains.
This issue has been seen in the following Microsoft Office applications, but it can potentially affect all Office apps:
This issue has been seen in the following Microsoft Office applications, but it can potentially affect all Office apps:
- Microsoft Excel
- Microsoft Photo Viewer
- Microsoft OneNote
Cause
When Microsoft Office saves a file, it uses a .tmp file for speed and performance. Also to ensure that there is always a persistent copy of the original data in the event of corruption during the save. The normal flow of a file save in Microsoft Office is the following:
The conditions which can produce this issue are:
- Create temp file
- Write changes to temp file
- Delete original file
- Rename temp file to target name
The conditions which can produce this issue are:
- Having migrated the CIFS file system in question using IMT
- The CIFS file system containing more than 4.2 billion files.
Resolution
Fix
The issue has been addressed in the latest Unity OE version of 5.0.2.0.5.009 which is available on the Dell EMC support website.
Contact Dell EMC Technical Support or your Authorized Service Representative, and quote this Knowledgebase article ID.
Workaround
If you have experienced the issue, renaming the tmp files to their original name brings back the file prior to the change.
The issue has been addressed in the latest Unity OE version of 5.0.2.0.5.009 which is available on the Dell EMC support website.
Contact Dell EMC Technical Support or your Authorized Service Representative, and quote this Knowledgebase article ID.
Workaround
If you have experienced the issue, renaming the tmp files to their original name brings back the file prior to the change.
Affected Products
Dell EMC Unity FamilyProducts
Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500
, Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition
...
Article Properties
Article Number: 000055676
Article Type: Solution
Last Modified: 15 Dec 2022
Version: 4
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