Avamar Exchange kończy się niepowodzeniem z błędem: avexvss: Odwołanie do obiektu nie jest ustawione na wystąpienie obiektu
Resumen: Niepowodzenie tworzenia kopii zapasowej Avamar Exchange z błędem: avexvss Error <0000>: Odwołanie do obiektu nie jest ustawione na instancję obiektu.
Síntomas
Niepowodzenie tworzenia kopii zapasowej DAG Avamar Exchange zawiera listę następujących błędów:
avexvss Error <0000>: Object reference not set to an instance of an object. avexvss Error <0000>: at ps_calls.is_db_mounted_by_guid(String msg_parms) avexvss Error <13247>: Failed to execute PowerShell command: Get-MailboxDatabase XXXXXXX-XXXXXXX-XXXXXXXXX-XXXXXXX
Causa
Od wersji 7 Avamar wprowadzono nową walidację w celu sprawdzenia członkostwa grupy kont Exchange "AvamarBackupUser" w usłudze Active Directory przed rozpoczęciem tworzenia kopii zapasowej/przywracania.
Ten błąd kopii zapasowej wydaje się być spowodowany problemem z sprawdzaniem poprawności w niektórych środowiskach (prawdopodobnie powolna usługa AD).
Poświadczenia w zestawie danych nie są prawidłowe.
Resolución
Poświadczenia powinny zostać usunięte w opcjach zestawu danych. Należy to zrobić, gdy konta usług są uruchomione jako konto usługi "AvamarBackupUser" lub konto obsługi klienta, a nie jako konto "systemu lokalnego".
Jeśli używasz konta "Local System", sprawdź dwukrotnie konto i hasło zdefiniowane w zestawie danych.
Sprawdzanie poprawności można pominąć z flagą avexvss.cmd "disable-membership-check" ustawioną na "true".
Jeśli konto kopii zapasowej zostało poprawnie skonfigurowane przy użyciu narzędzia "Avamar Exchange Backup User Configuration Tool", tworzenie kopii zapasowej lub przywracanie powinno rozpocząć się bez dalszych problemów.
Aby zastosować flagę, wykonaj następującą procedurę:
- Przejdź do udostępnionego folderu var "Avamar DAG".
- Edytuj plik avexvss.cmd za pomocą notatnika.
- Dodaj następującą flagę.
--disable-membership-check=true
- Zapisz i zamknij plik.
- Przejdź do lokalnego folderu var w każdym węźle programu Exchange i utwórz plik, avexvss.cmd jeśli jeszcze nie istnieje, a następnie dodaj tę samą flagę.
- Uruchom ponownie kopię zapasową.
Jeśli problem będzie się powtarzał, otwórz zgłoszenie serwisowe w dziale pomocy technicznej i podaj ten numer KB: 528519