Avamar Exchange misslyckas med felet: avexvss: Objektreferensen är inte inställd på en instans av ett objekt
Resumen: Avamar Exchange-säkerhetskopiering misslyckas med fel: avexvss-fel <0000>: Object reference not set to an instance of an object.
Síntomas
Följande fel visas vid säkerhetskopieringsfel i Avamar Exchange DAG:
avexvss Error <0000>: Object reference not set to an instance of an object. avexvss Error <0000>: at ps_calls.is_db_mounted_by_guid(String msg_parms) avexvss Error <13247>: Failed to execute PowerShell command: Get-MailboxDatabase XXXXXXX-XXXXXXX-XXXXXXXXX-XXXXXXX
Causa
Sedan Avamar version 7 har en ny validering introducerats för att kontrollera kontogruppsmedlemskapet för Exchange "AvamarBackupUser" med Active Directory innan säkerhetskopieringen/återställningen startar.
Det här säkerhetskopieringsfelet verkar orsakas av ett problem med valideringskontrollen i vissa miljöer (möjligen långsam AD).
Autentiseringsuppgifterna i datauppsättningen är inte korrekta.
Resolución
Autentiseringsuppgifter bör tas bort i datauppsättningsalternativen. Detta bör göras när tjänstkonton körs som tjänstkontot "AvamarBackupUser" eller kundtjänstkontot och inte körs som kontot "Lokalt system".
Om du kör som kontot "Lokalt system" dubbelkollar du kontot och lösenordet som definierats i datauppsättningen.
Valideringskontrollen kan hoppas över med avexvss.cmd-flaggan "disable-membership-check" inställd på "true".
Om kontot för säkerhetskopiering har konfigurerats korrekt med hjälp av Avamar Exchange Backup User Configuration Tool bör säkerhetskopieringen eller återställningen starta utan ytterligare problem.
Så här använder du flaggan:
- Bläddra till den delade var-mappen "Avamar DAG".
- Redigera filen avexvss.cmd med anteckningar.
- Lägg till följande flagga.
--disable-membership-check=true
- Spara och stäng filen.
- Bläddra till den lokala var-mappen på varje Exchange-nod och skapa filen avexvss.cmd om den inte redan finns och lägg till samma flagga.
- Kör säkerhetskopieringen igen.
Om problemet kvarstår öppnar du en tjänstebegäran hos supporten och anger KB-numret: 528519