Avamar: SQL Backup completed with the exception: Force Incremental after full is failing with the error: "Error: A log gap was identified, or a full backup was not found"

Resumen: Avamar SQL Backup completed with exception: Force Incremental after full is failing with the error: "Error: A log gap was identified, or a full backup was not found"

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Síntomas

Avamar SQL backup for AlwaysON Databases completes with exceptions.
Force Incremental backup after full is failing with the error: "Error: A log gap was identified, or a full backup was not found"

Here is the snippet from the log:
2017/11/09-18:48:57.86599 [avsql_assist]  ===> sqlconnect::~sqlconnect
2017/11/09-18:48:57.86599 [avsql_assist]  <=== sqlconnect::~sqlconnect
2017/11/09-18:48:57.86599 [avsql_assist]  <=== avsql_assist::snapup_check_timestamps
2017-11-09 13:48:57 avsql Error <15762>: Skipping incremental backup after full for <AlwaysON_DB_Name> database. Error: A log gap was identified or a full backup was not found.
Secondary Replica is selected for the backup in the Dataset.
There is not a third-party or native backup taken.

Causa

Log Sequence Number (LSN) number in the SQL Server and backup metadata is not matching.
The issue is caused when a Full + incremental backups are taken on Primary Replica.
 

Resolución

To resolve this issue, upgrade the Avamar Server to the following Avamar software release:
  • 19.4.100-124 or later

Productos afectados

Avamar

Productos

Avamar
Propiedades del artículo
Número del artículo: 000065986
Tipo de artículo: Solution
Última modificación: 07 mar 2024
Versión:  9
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