Asset sizes Not showing up in the UI for SQL database backups
Resumen: After SQL Backups run Successfully, and then viewing the SQL Assets, some of the databases are not reporting the Size. The sizes are empty.
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Screenshot below shows that database sizes are circled in Orange, but no sizes are shown for several of the databases with the Green Arrow.
Causa
You must ensure that database OS account or NT AUTHORITY or SYSTEM account that is being used on each SQL host has the required sysadmin privilege. By default, the Microsoft application agent uses the SYSTEM account for asset discovery and this requires granting the SYSTEM account the Microsoft SQL Server sysadmin role.
Resolución
Setting the sysadmin privilege for database OS account:
Complete the following steps to ensure that the database OS account on each host has the sysadmin privilege.- Log in to each Microsoft SQL Server instance > open SQL Server Management Studio (SSMS) > select View > Object Explorer.
- Go to Object Explorer > expand Security > expand Logins.
- Right-click the Database OS Account Name, and then select Properties.
- In the Login Properties window, select Server Roles.
- Select sysadmin under Server Roles.
- Click OK. The Login properties window closes.
- On the PowerProtect Data Manager UI, select Infrastructure > Asset Sources > select SQL tab.
- Select the required Hostname in the list, and then click Edit Credentials.
- On the Set Credential page, specify the Database OS credentials, and select the option Use the credentials for both asset discovery and backup.
NOTE: On the Set Credential page, the option Use the credentials for both asset discovery and backup does not appear when the database OS credentials setting is None or the application agent release is before 19.11.
- Click Save.
Setting the sysadmin privilege for NT AUTHORITY\SYSTEM account
Complete the following steps to ensure that the NT AUTHORITY\SYSTEM account on each host has the sysadmin privilege.
- Log in to each Microsoft SQL Server instance > open SQL Server Management Studio (SSMS) > select View > Object Explorer.
- Go to Object Explorer > expand Security > expand Logins.
- Right-click NT AUTHORITY\SYSTEM, and then select Properties.
- In the Login Properties window, select Server Roles.
- Select sysadmin under Server Roles.
- Click OK. The Login properties window closes.
Información adicional
If this does not comply with security requirements as an alternative, you can select the option 'Use the credentials for both asset discovery and backup' which uses a domain or local user account instead for the Asset Discovery.
This option can be selected on the 'Set Credential' page in the PowerProtect Data Manager UI.
This option can be selected on the 'Set Credential' page in the PowerProtect Data Manager UI.
More details are seen in Chapter 3: Managing Storage, Assets, and Protection, of the PowerProtect Data Manager 19.13 SQL User Guide.
Productos afectados
PowerProtect Data Manager Appliance, PowerProtect Data Manager Software, PowerProtect DM5500Propiedades del artículo
Número del artículo: 000215752
Tipo de artículo: Solution
Última modificación: 28 jul 2023
Versión: 2
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.