Rozmiary zasobów, które nie są wyświetlane w interfejsie użytkownika kopii zapasowych bazy danych SQL
Resumen: Po pomyślnym uruchomieniu programu SQL Backup, a następnie wyświetleniu zasobów SQL niektóre z baz danych nie zgłaszają rozmiaru. Rozmiary są puste.
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Poniższy zrzut ekranu pokazuje rozmiary baz danych wyróżnione na pomarańczowo, ale nie są wyświetlane żadne rozmiary dla kilku baz danych z zieloną strzałką.
Causa
Należy upewnić się, że konto systemu operacyjnego bazy danych lub konto NT AUTHORITY/SYSTEM używane na poszczególnych hostach SQL ma wymagane uprawnienia sysadmin. Domyślnie agent aplikacji Microsoft używa konta SYSTEM do wykrywania zasobów, co wymaga przyznania kontu SYSTEM roli sysadmin programu Microsoft SQL Server.
Resolución
Ustawianie uprawnień sysadmin dla konta
systemu operacyjnego bazy danychWykonaj następujące czynności, aby upewnić się, że konto systemu operacyjnego bazy danych na każdym hoście ma uprawnienia sysadmin.
1. Zaloguj się do każdej instancji programu Microsoft SQL Server, otwórz program SQL Server Management Studio (SSMS) i wybierz opcję Wyświetl > Eksploratora obiektów
.
2. W Eksploratorze obiektów rozwiń eksplorator zabezpieczeń, a następnie rozwiń loginy.
3. Kliknij prawym przyciskiem myszy nazwę konta systemu operacyjnego bazy danych, a następnie wybierz polecenie Właściwości.
4. W oknie Właściwości logowania wybierz pozycję Role serwera.
5. Wybierz sysadmin w sekcji Role serwera.
6. Kliknij przycisk OK.
Okno właściwości logowania zostanie zamknięte.
7. W interfejsie użytkownika PowerProtect Data Manager wybierz opcję Infrastructure > Asset Sources, a następnie wybierz kartę SQL.
8. Wybierz odpowiednią nazwę hosta na liście, a następnie kliknij przycisk Edytuj poświadczenia.
9. Na stronie Set Credential określ poświadczenia systemu operacyjnego bazy danych i wybierz opcję Użyj poświadczeń do
wykrywania zasobów i tworzenia kopii zapasowej.
UWAGA: Na stronie Set Credential opcja Użyj poświadczeń do wykrywania zasobów i tworzenia kopii zapasowej nie
jest wyświetlana, gdy ustawienie poświadczeń systemu operacyjnego bazy danych to None lub wersja agenta aplikacji jest wcześniejsza niż 19.11.
10. Kliknij przycisk Zapisz.
Ustawianie uprawnień sysadmin dla konta
NT AUTHORITY\SYSTEMWykonaj następujące czynności, aby upewnić się, że konto NT AUTHORITY\SYSTEM na każdym hoście ma uprawnienia sysadmin.
1. Zaloguj się do każdej instancji programu Microsoft SQL Server, otwórz program SQL Server Management Studio (SSMS) i wybierz opcję Wyświetl > Eksploratora obiektów
.
2. W Eksploratorze obiektów rozwiń eksplorator zabezpieczeń, a następnie rozwiń loginy.
3. Kliknij prawym przyciskiem myszy pozycję NT AUTHORITY\SYSTEM, a następnie wybierz polecenie Właściwości.
4. W oknie Właściwości logowania wybierz pozycję Role serwera.
5. Wybierz sysadmin w sekcji Role serwera.
6. Kliknij przycisk OK.
Okno właściwości logowania zostanie zamknięte.
systemu operacyjnego bazy danychWykonaj następujące czynności, aby upewnić się, że konto systemu operacyjnego bazy danych na każdym hoście ma uprawnienia sysadmin.
1. Zaloguj się do każdej instancji programu Microsoft SQL Server, otwórz program SQL Server Management Studio (SSMS) i wybierz opcję Wyświetl > Eksploratora obiektów
.
2. W Eksploratorze obiektów rozwiń eksplorator zabezpieczeń, a następnie rozwiń loginy.
3. Kliknij prawym przyciskiem myszy nazwę konta systemu operacyjnego bazy danych, a następnie wybierz polecenie Właściwości.
4. W oknie Właściwości logowania wybierz pozycję Role serwera.
5. Wybierz sysadmin w sekcji Role serwera.
6. Kliknij przycisk OK.
Okno właściwości logowania zostanie zamknięte.
7. W interfejsie użytkownika PowerProtect Data Manager wybierz opcję Infrastructure > Asset Sources, a następnie wybierz kartę SQL.
8. Wybierz odpowiednią nazwę hosta na liście, a następnie kliknij przycisk Edytuj poświadczenia.
9. Na stronie Set Credential określ poświadczenia systemu operacyjnego bazy danych i wybierz opcję Użyj poświadczeń do
wykrywania zasobów i tworzenia kopii zapasowej.
UWAGA: Na stronie Set Credential opcja Użyj poświadczeń do wykrywania zasobów i tworzenia kopii zapasowej nie
jest wyświetlana, gdy ustawienie poświadczeń systemu operacyjnego bazy danych to None lub wersja agenta aplikacji jest wcześniejsza niż 19.11.
10. Kliknij przycisk Zapisz.
Ustawianie uprawnień sysadmin dla konta
NT AUTHORITY\SYSTEMWykonaj następujące czynności, aby upewnić się, że konto NT AUTHORITY\SYSTEM na każdym hoście ma uprawnienia sysadmin.
1. Zaloguj się do każdej instancji programu Microsoft SQL Server, otwórz program SQL Server Management Studio (SSMS) i wybierz opcję Wyświetl > Eksploratora obiektów
.
2. W Eksploratorze obiektów rozwiń eksplorator zabezpieczeń, a następnie rozwiń loginy.
3. Kliknij prawym przyciskiem myszy pozycję NT AUTHORITY\SYSTEM, a następnie wybierz polecenie Właściwości.
4. W oknie Właściwości logowania wybierz pozycję Role serwera.
5. Wybierz sysadmin w sekcji Role serwera.
6. Kliknij przycisk OK.
Okno właściwości logowania zostanie zamknięte.
Información adicional
Jeśli nie spełnia to wymogów zabezpieczeń jako alternatywa, można wybrać opcję "Użyj poświadczeń zarówno do wykrywania zasobów, jak i tworzenia kopii zapasowych", które będzie korzystać z konta użytkownika domeny lub lokalnego zamiast wykrywania zasobów.
– Tę opcję można wybrać na stronie Set Credential (Ustaw poświadczenia) w interfejsie użytkownika PPDM.
– Tę opcję można wybrać na stronie Set Credential (Ustaw poświadczenia) w interfejsie użytkownika PPDM.
Dodatkowe informacje na stronie 49 podręcznika użytkownika PPDM 19.13 SQL
Productos afectados
PowerProtect Data Manager Appliance, PowerProtect Data Manager Software, PowerProtect DM5500Propiedades del artículo
Número del artículo: 000215752
Tipo de artículo: Solution
Última modificación: 28 jul 2023
Versión: 2
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.