CloudLink: Se muestra el error "No se puede recuperar el certificado solicitado"
Resumen: En vCenter, cuando intenta establecer la confianza con CloudLink, recibe el mensaje de error "No se puede recuperar el certificado solicitado".
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No se identifican todas las versiones del producto en este artículo.
Síntomas
En vCenter, no se puede establecer la confianza con CloudLink durante la configuración inicial del proveedor de claves.
Reciba un mensaje de error como el que se muestra a continuación:
Reciba un mensaje de error como el que se muestra a continuación:
Cannot retrieve the requested certificate
Causa
Una causa de este error es que vCenter no puede comunicarse con CloudLink a través del puerto 5696.
Otra posible causa es que el usuario está ejecutando versiones de CloudLink y vCenter que no son compatibles.
Otra posible causa es que el usuario está ejecutando versiones de CloudLink y vCenter que no son compatibles.
Resolución
- Acceda mediante SSH al dispositivo vCenter
- Ejecute los siguientes comandos:
ping cloudlinkip curl -v telnet://cloudlinkip:5696 curl -v --local-port 10000 telnet://cloudlinkip:5696 curl -v --local-port 20000 telnet://cloudlinkip:5696 curl -v --local-port 30000 telnet://cloudlinkip:5696 curl -v --local-port 40000 telnet://cloudlinkip:5696 curl -v --local-port 50000 telnet://cloudlinkip:5696 curl -v --local-port 60000 telnet://cloudlinkip:5696
- Si los comandos ping o curl fallan, esto puede indicar un problema de firewall o de red. El usuario debe consultar con el equipo de red , asegurarse de que los puertos necesarios estén abiertos y confirmar que las VM de CloudLink estén en la red o VLAN correctas.
- Si los comandos curl se ejecutan correctamente, se recibe un mensaje que dice "Conectado a x.x.x.x", como se muestra en esta captura de pantalla:
- Si los comandos ping y curl o telnet se ejecutan correctamente, compruebe que las versiones de CloudLink y vCenter sean compatibles. Es posible que reciba el mensaje de error No se puede recuperar el certificado solicitado si se utiliza vCenter 8.x con CloudLink 7.1.7 o anterior. Consulte la Guía
de compatibilidad de VMware para conocer las versiones compatibles de vCenter y CloudLink
CloudLink 7.0 es compatible con vCenter 6.x y 7.x.
CloudLink 7.1.x es compatible con vCenter 6.x y 7.x.
CloudLink 8.x es compatible con vCenter 7.x y 8.x.
CloudLink 8.x es la versión oficialmente compatible con vCenter 8.x; sin embargo, CloudLink 7.1.8 y 7.1.9 parecen funcionar con vCenter 8.x.
CloudLink 7.1.x es compatible con vCenter 6.x y 7.x.
CloudLink 8.x es compatible con vCenter 7.x y 8.x.
CloudLink 8.x es la versión oficialmente compatible con vCenter 8.x; sin embargo, CloudLink 7.1.8 y 7.1.9 parecen funcionar con vCenter 8.x.
- La actualización de CloudLink a 7.1.8, 7.1.9 u 8.x debería abordar el problema y poder establecer confianza.
Exención de responsabilidad: Si el usuario ejecuta PowerFlex, es posible que no pueda actualizar a ciertas versiones de CloudLink. Deben permanecer en la versión de CloudLink que se indica en su RCM.
Productos afectados
CloudLinkPropiedades del artículo
Número del artículo: 000223969
Tipo de artículo: Solution
Última modificación: 13 nov 2025
Versión: 4
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