PowerStore: Evaluación del estado previa a la actualización (PUHC) para identificar entradas NTP duplicadas
Resumen: Esta evaluación del estado verifica dos cosas: (1) que no se configuren direcciones IP de servidor Network Time Protocol (NTP) duplicadas y (2) que todos los ajustes de NTP sean coherentes internamente. ...
Síntomas
La evaluación del estado previa a la actualización (PUHC) de PowerStore falla con el siguiente error: cyc_ntp_addresses_duplication_check_error

Sin esta evaluación del estado, los clientes corren el riesgo de experimentar fallas de actualización debido a configuraciones duplicadas de IP del servidor NTP. PowerStore OS permanece en un estado parcialmente actualizado, lo que requiere intervención manual y pasos de reversión o recuperación. Esto puede provocar un tiempo de inactividad prolongado y demoras en la programación de actualizaciones, lo que afecta la disponibilidad del servicio.
Causa
La falla se desencadena por direcciones IP duplicadas del servidor NTP configuradas en el sistema, lo que provoca actualizaciones del identificador único universal (UUID) no coincidentes entre System Manager (SYM) y la base de datos de administración interna.
Por lo general, esta condición se produce cuando se agregan varios servidores NTP idénticos manualmente durante la instalación inicial a través del asistente de configuración inicial (ICW) o mediante la interfaz de línea de comandos de PowerStore (PSTCLI) antes de iniciar la actualización.
Resolución
No continúe con la NDU hasta que se resuelva el problema:
Elimine las entradas duplicadas del servidor NTP antes de volver a intentar la actualización. La configuración de NTP se puede validar desde la interfaz del usuario de PowerStore Manager o PSTCLI como se indica en este ejemplo:
cli> ntp show
# | id | addresses
----+------+---------------
1 | NTP1 | 10.244.53.108
| | 10.228.254.66
Si la configuración no tiene entradas duplicadas del servidor NTP o la PUHC aún falla después de quitar los duplicados, esto indica una incoherencia entre System Manager (SYM) y la base de datos de administración. Póngase en contacto con el servicio de soporte para abordar este problema.