Dell EMC Unity : Certains fichiers Microsoft Office sont enregistrés de manière incorrecte (corrigible par l’utilisateur)
Résumé: Dans le code Dell EMC Unity niveau 5.0, un problème a été introduit, où les fichiers modifiés à partir de Microsoft Excel et de Photo Viewer ne sont pas enregistrés correctement.
Cet article concerne
Cet article ne concerne pas
Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
Après la mise à niveau de la baie Dell EMC Unity vers le niveau de code 5.0, lors de la modification des fichiers Microsoft Office existants, les modifications ne sont pas enregistrées à la fermeture. Au lieu de cela, il reste un fichier .tmp.
Ce problème a été observé dans les applications Microsoft Office suivantes, mais il peut potentiellement affecter toutes les applications Office :
Ce problème a été observé dans les applications Microsoft Office suivantes, mais il peut potentiellement affecter toutes les applications Office :
- Microsoft Excel
- Visionneuse de photos Microsoft
- Microsoft OneNote
Cause
Lorsque Microsoft Office enregistre un fichier, il utilise un fichier .tmp pour plus de vitesse et de performances. Il permet également de s’assurer qu’il existe toujours une copie persistante des données d’origine en cas de corruption lors de la sauvegarde. Le flux normal d’une sauvegarde de fichier dans Microsoft Office est le suivant :
Les conditions pouvant entraîner ce problème sont les suivantes :
- Créer un fichier temporaire
- Écrire les modifications dans le fichier temporaire
- Supprimer le fichier d’origine
- Renommer le fichier temporaire en nom cible
Les conditions pouvant entraîner ce problème sont les suivantes :
- Avoir migré le système de fichiers CIFS en question à l’aide d’IMT
- Système de fichiers CIFS contenant plus de 4,2 milliards de fichiers.
Résolution
Réparer
Le problème a été résolu dans la dernière version d’Unity OE 5.0.2.0.5.009, disponible sur le site Web de support Dell EMC.
Contactez le support technique Dell EMC ou votre représentant de service agréé en leur communiquant l’ID de cet article de la base de connaissances.
Solution de contournement
Si vous avez rencontré le problème, le fait de renommer les fichiers tmp avec leur nom d’origine permet de rétablir le fichier avant la modification.
Le problème a été résolu dans la dernière version d’Unity OE 5.0.2.0.5.009, disponible sur le site Web de support Dell EMC.
Contactez le support technique Dell EMC ou votre représentant de service agréé en leur communiquant l’ID de cet article de la base de connaissances.
Solution de contournement
Si vous avez rencontré le problème, le fait de renommer les fichiers tmp avec leur nom d’origine permet de rétablir le fichier avant la modification.
Produits concernés
Dell EMC Unity FamilyProduits
Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500
, Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition
...
Propriétés de l’article
Numéro d’article: 000055676
Type d’article: Solution
Dernière modification: 15 déc. 2022
Version: 4
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.