Échec des sauvegardes de reprise après sinistre du serveur PowerProtect avec AccessDeniedException
Résumé: Les sauvegardes de reprise après sinistre (DR) du serveur PowerProtect Data Manager Appliance échouent avec une exception AccessDeniedException pour le répertoire /data01/serverdr_staging/postgres_pwd. ...
Cet article concerne
Cet article ne concerne pas
Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
Les sauvegardes de reprise après sinistre (DR) du serveur de l’appliance PowerProtect Data Manager échouent avec une exception. La commande /var/log/brs/serverdr/serverdr.log Montre:
YYYY-MM-DD HH:MM:SS ERROR [] [createBackupAsync-2] [][][][TRACE_ID:8d1eb37a6d33f4df;JOB_ID:90a8dc6d7559f55d][] [c.e.d.e.c.s.c.u.SdrUtils.createFailedErrorMessage(570)] - Generating failed error message
java.nio.file.AccessDeniedException: /data01/serverdr_staging/postgres_pwd
at java.base/sun.nio.fs.UnixException.translateToIOException(UnixException.java:90)
at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)
at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:116)
..
..
"name" : "Create a Server Disaster Recovery backup - by Scheduler",
"category" : "DISASTER_RECOVERY",
"subcategory" : null,
"ancestryId" : "93ad5efc-b72c-44c5-9638-44093885b358",
"parentId" : "36b9c1ef-fe95-478c-90a8-dc6d7559f55d",
"classType" : "TASK",
"source" : {
"type" : "DATA_MANAGER",
"id" : null,
"description" : null
},
"result" : {
"status" : "FAILED",
"summaries" : [ "BackUp ID : b75cfb53-4859-4f8c-839e-a4073a91f32b", "Backup Name : SystemDR-1662050537324", "PPDM Backup : PPDM Task Id : 7f23a861-1dc9-4b7a-8c28-84ac81df6956", "Available PPDM Storage : 0.0 B (0 Bytes)", "Backup Size : 47.2
3 MB (47230767 Bytes)", "Tar file size : 79.56 MB (79557831 Bytes)", "FAILED" ],
"error" : {
"code" : "ASDR0001",
"reason" : "/data01/serverdr_staging/postgres_pwd",
"detailedDescription" : "The Server Disaster Recovery backup cannot be completed.",
"remediation" : "Please review the log files at /var/log/brs/serverdr for more detailed information or contact support if the issue persists.",
Cause
Les autorisations incorrectes sont configurées pour le /data01/serverdr_staging/postgres_pwd . La cause des autorisations incorrectes n’est pas connue.
admin@my-ppdm:~> ls -l /data01/serverdr_staging/ total 1292 drwxr-xr-x 3 elasticsearch elasticsearch 292 Sep 8 12:57 elasticsearch drwx------ 3 admin admin 17 Aug 26 10:42 etc drwx------ 5 admin admin 138 Sep 8 12:57 lockbox drwx------ 5 admin admin 138 Sep 8 12:57 pgsql -rw------- 1 root root 48 Jul 21 14:14 postgres_pwd drwx------ 2 admin admin 32 Aug 26 10:42 resiliency
Résolution
Mettez à jour les autorisations pour le /data01/serverdr_staging/postgres_pwd .
- Ouvrez une session SSH sur PowerProtect Data Manager et authentifiez-vous avec le compte admin.
- Utilisez la commande
suet authentifiez-vous avec le mot de passe root :sudo su Update the postgres_pwd directory permissions:chmod 777 postgres_pwdUpdate the postgres_pwd directory owner: chown admin:admin postgres_pwd
Produits concernés
PowerProtect SoftwarePropriétés de l’article
Numéro d’article: 000203174
Type d’article: Solution
Dernière modification: 23 déc. 2025
Version: 5
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.