Errore di scansione driver della riga di comando di Dell Command Update

Résumé: Ulteriori informazioni su Dell Command | Errore di scansione del driver di aggiornamento, "Nessuna informazione di aggiornamento disponibile. Il sistema non è supportato dai cataloghi disponibili." ...

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Dell Command | L'aggiornamento contiene lo strumento dell'interfaccia della riga di comando (CLI) dcu-cli.exe. Ciò consente agli amministratori di usufruire delle capacità di configurazione di Dell Command | Gestione degli aggiornamenti e dei driver dal prompt dei comandi di Windows o da PowerShell.

La scansione degli aggiornamenti dei driver non riesce e restituisce l'errore "Nessuna informazione sull'aggiornamento disponibile. Il sistema non è supportato dai cataloghi disponibili." Questo errore si verifica quando è in uso un file XML di TechDirect Custom Driver Catalog.

Un esempio di comando che potrebbe non riuscire con questo errore è:
dcu-cli /scan -cataloglocation=C:\temp\CUSTOM_CATALOG.xml

Nessuna informazione sull'aggiornamento

Prodotti interessati:

  • Dell Command | Update

Cause

Questo messaggio di errore è fuorviante, perché i test condotti da Dell dimostrano che il modello utilizzato è supportato. Verificare che il modello sia supportato facendo riferimento a Dell Command | Pagina dei dettagli del driver dell'applicazione aggiornata nel Supporto Dell e facendo riferimento ai Sistemi compatibili.

L'opzione richiesta -allowXML Lo switch è ancora in uno stato disabilitato (predefinito), causando l'errore.

-allowXML: Consente all'utente di abilitare o disabilitare l'utilizzo del file di catalogo XML

Résolution

I comandi corretti richiesti per eseguire la scansione con un file XML di TechDirect Custom Driver Catalog in uso sono i seguenti:

  • dcu-cli /configure -allowXML=enable
  • dcu-cli /scan -cataloglocation=C:\temp\CUSTOM_CATALOG.xml

Se il problema persiste, verificare che siano state selezionate le piattaforme Dell corrette durante il processo di creazione del file XML del catalogo driver personalizzato TechDirect.

Informations supplémentaires

Per ulteriori informazioni sulla riga di comando, consultare il documento Dell Command | Sezione Aggiornamento dell'interfaccia della riga di comando di Dell Command | Guida di riferimento per l'aggiornamento dal supporto per i manuali e la documentazione di Dell Command Update.

Produits concernés

OptiPlex, Latitude, XPS, Fixed Workstations, Mobile Workstations, Dell Command | Update
Propriétés de l’article
Numéro d’article: 000223721
Type d’article: Solution
Dernière modification: 25 août 2025
Version:  3
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.