Data Domain: Configurazione, controlli della topologia e test dei cavi SAS

Riepilogo: Questo articolo aiuta a risolvere i possibili problemi di connessione dei cavi sui collegamenti SAS agli alloggiamenti e agli enclosure di storage collegati.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Configurazione e test
dei cavi SASSe un cavo SAS è difettoso, il sistema può essere lento, in grado di causare le seguenti condizioni di errore in Autosupport e il relativo meccanismo di allerta.

SCOPO:
Questo articolo elenca i passaggi per garantire che:

  • I cavi SAS (Serial Attached SCSI) sono configurati utilizzando la topologia corretta e che
  • I connettori dei cavi sono fissati in modo sicuro e supportano il throughput dati necessario
  • Assicurarsi della topologia corretta per la configurazione dello storage
  • Accertarsi che i connettori siano fissati saldamente
  • Test delle connessioni dei cavi e del throughput dei dati
SI APPLICA A:
  • Sistemi Data Domain con storage esterno 
  • Tutte le release del software

Causa

Se un cavo SAS è difettoso, il sistema può riscontrare lentezza che può causare e segnalare le seguenti condizioni di errore in Autosupport (ASUP) e il relativo meccanismo di allerta:

  • Enclosure multipath path fails back to single path
  • avviso WWN duplicato 50050cc1011820cf found in 3.B.?, Loop back alla porta HBA 4a
  • Encl <ID> enclosure (<#> seriale enclosure) L'ID> del disco <dispone di un solo percorso di connessione attivo e il numero richiesto è 2
  • L'ID> disco del disco <è assente e deve essere sostituito
  • L'ID> disco del disco <è guasto e deve essere sostituito
  • L'ID> del disco <è sconosciuto e deve essere sostituito
  • In un enclosure, è possibile visualizzare più dischi in uno stato assente, guasto, sconosciuto o anche in uno stato noto
  • ".se enclosure show detailed-status 2" visualizza "Velocità di <collegamento della porta N host o EXP 12,0 Gbps su ES20" O "<24 Gbps" su un ES30 o DS60
  • ".se enclosure show detailed-status 2" visualizza "Velocità di collegamento della porta N host o EXP 0,0 Gbps (disconnesso)"
  • Il collegamento difettoso visualizza 9,0 Gbps (ovvero <12,0 Gbps su ES20 O <24 Gbps su ES30/DS60)
Nota: I comandi SE devono essere eseguiti dalla modalità SE. Contattare il team di supporto per assistenza con i comandi in modalità SE.

Risoluzione

  1. Verificare che il cavo SAS sia collegato e funzioni correttamente.

Al prompt dei comandi digitare:

enclosure show topology

Verificare che i percorsi primario e secondario di ciascun enclosure siano corretti senza punti interrogativi:
Conferma della validità dei percorsi primario e secondario

Un cavo SAS difettoso mostra punti interrogativi (???) tra i percorsi e il messaggio di errore che indica che è stato rilevato un problema:

Port      enc.ctrl.port        enc.ctrl.port       enc.ctrl.port
3a    >   5.A.H:5.A.E   ? ? ?  7.B.H:7.B.E    >    6.B.H:6.B.E 

Messaggio di errore: ? giallo - È stato rilevato un possibile problema per questo controller a scaffale o per il cavo ad esso collegato.

  1. Se vengono visualizzati punti interrogativi (?) tra i percorsi, ispezionare fisicamente la connettività del cavo SAS tra gli alloggiamenti. Tuttavia, se tutti i cavi sono ben chiusi e fissati saldamente, l'avviso non scompare, è necessaria un'ulteriore procedura di risoluzione dei problemi. Contattare il Supporto Dell e creare una Service Request.
  2. Se vengono visualizzati punti esclamativi (!) tra i percorsi, significa che è stato registrato un errore PHY. Contattare il supporto Dell per assistenza nell'esecuzione della diagnostica:
Port      enc.ctrl.port        enc.ctrl.port       enc.ctrl.port
3a    >   5.A.H:5.A.E     !    7.B.H:7.B.E     >   6.B.H:6.B.E  
  1. Cause di un avviso WWN duplicato:
  • Cavi allentati o difettosi
  • Connessione di una porta di espansione direttamente alla porta HBA (scheda SAS) (ad esempio 6.B.E > 4a)
  • Collegamenti errati tra enclosure nel collegamento a margherita

Controllare tutte le connessioni e verificare che il cablaggio sia indicato nella guida alle best practice di Data Domain. 
Una volta riparata, potrebbe essere necessario riavviare il sistema per reimpostare la catena.
Di seguito è riportato un esempio di connessione di un singolo alloggiamento DS60 con le velocità di connessione previste:

se enclosure show detailed-status 2 
Encl 2
         Model                   DS60
         Capacity                60 Slots
         WWN                     N/A
         Serial #                xxxxxxxxxx0056
         Number of Controllers   2

         Controller A
                        WWN        500604811017B07F
                        Firmware   2.10.1
                        Serial #   xxxxxxxxxx0162
                        Status     OK

         Expander   Device       Speed       Description
        ---------   ----------   ---------   -------------------------
                    HOST port    24.0 Gbps  <<< Expected connection speed 
                    EXP'N port   0.0 Gbps   <<< 0.0 Gbps will be displayed if there is no physical cable connected

Informazioni aggiuntive

Se si modifica il cablaggio SAS, tenere presente quanto segue: 
  • Per enclosure ES30 e FS15: Attendere almeno 2 minuti tra la rimozione o l'inserimento dei cavi sulle porte HBA SAS dell'unità principale.
  • Per enclosure DS60: Attendere almeno 8 minuti tra la rimozione o l'inserimento del cavo sulle porte HBA SAS dell'unità principale.
In questo modo l'unità principale (DDOS) ha il tempo di applicare gli aggiornamenti del firmware e la mappatura dei dispositivi richiesti sui componenti dell'enclosure collegato.

Riferimenti:

Prodotti interessati

Data Domain

Prodotti

Data Domain, Data Domain Deduplication Storage Systems, DS60, ES30
Proprietà dell'articolo
Numero articolo: 000035680
Tipo di articolo: Solution
Ultima modifica: 24 lug 2025
Versione:  9
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.